[Zigbee] What unit is the maximum reporting interval?

I have a Blitzwolf SHP13 “smart plug” and while it got added well into openHab, I’m having a hard time getting it to update its current and power channels.
I used to ssh console to run the following command:

zigbee endpoint 51205/1

Which gave me a very long list of attributes, among which the two that I’m interested in like this:

    S    1288 r-- UNSIGNED_16_BIT_INTEGER   RMS Current                              Sun Sep 18 12:05:20 CEST 2022 139
    S    1291 r-- SIGNED_16_BIT_INTEGER     Active Power                             Sun Sep 18 12:04:52 CEST 2022 18

I then used the reportcfg command on the 1288 attribute which gave me the following result:

Cluster 2820, Attribute 1288, type UNSIGNED_16_BIT_INTEGER, minimum reporting interval: 3, maximum reporting interval: 7200, timeout: 0

What is the unit of time used for “maximum reporting interval”? I’m asking because, if it’s seconds, then 7200 is 2 hours and yet, according to the reportcfg result, the last update to the values has been more than 24 hours ago.

If it’s indeed seconds, what could explain that it does not update on a regular basis? In particular, why doesn’t it update when the plug gets turned off?

Well, I left it untouched for 5 days, and the zigbee endpoint report showed that the value has not been updated ever since.
However, if I open the “Thing” page and simply click the Save text at the top right, then the value is immediately updated.
I also tried showing the “Channel details” page for any of the channel. When I click “Done” at the top right, it also updates the values, and for all channels.

It’s as if the device needs to be queried for values, rather than sending them on a periodical basis.
Is this something plausible? If yes, is there a way to setup some sort of a polling read?