Zigbee Xiaomi/Aqara sensors - cannot add more than one

Tags: #<Tag:0x00007f6170711690>

Hi,
new Zigbee user here :slight_smile:
Managed to add my Nortek GoControl zigbee coordinator, and 3 Xiaomi/Aqara (square) senzors for temperature and humidity.
At some point I had all 3 working fine, but then suddenly 2 of them somehow fell out from the network.
And now I cannot get them back to show as online, whatever I try (reboot, reset the sensor and try to discover it in inbox again, no luck). Even tried getting the USB dongle near the sensor, still not showing as online.
Is it a known issue?
funny part is that the only sensor working is the one outside on the balcony and 2 that are very close to the controller (2-3 meters) are offline.

system is openhab 2.4. do you think upgrade to 2.5 would make zigbee more usable/stable? I’m afraid to upgrade as I have many devices/bindings including KNX system…
running on RPI3

thanks

managed to re-add another. so only 1 is out. it very unstable, hit and miss…

So, I have upgraded OH from 2.4 to 2.5 in hope of getting more stable/usable zigbee experience with those aqara sensors, but now it’s even worse, completely broken.

The best I can get is device OFFLINE. Node has not completed discovery
previously on OH2.4 i was at least getting them online and reading temperatures from them, but they kept falling offline/off the network.

As I understand from the other posts, the only way to properly use those aqara sensors is with mqtt2zigbee. So I am ordering one of those zigbee sniffers and going down that route, clearly official zigbee binding cannot handle non standard xiaomi devices well…