Zigbee2mqtt + OH3 + xiaomi wall single switch (qbkg04lm)

Tags: #<Tag:0x00007f4341915010> #<Tag:0x00007f4341914f20> #<Tag:0x00007f4341914de0>

Hi, I use zigbee2mqtt in OH3 with qbkg04lm, and successfully connect them together (turn on/off from interface and get a status update from the physical button press). But I don’t know how to change wall switch mode (like it can be done in the official MIhome app), for example qbkg04lm can work in two modes:

  • first mode is when I press the physical button, the relay turns on/off light and updates status in OH (this mode i have already)
  • second mode is when I press the physical button, relay don’t do anything, only send command to OH (this mode I want to enable to my scenarios).

I find this documentation, but it not helps(((
Future thx

It looks like you need to use the decoupled mode via zigbee2mqtt/FRIENDLY_NAME/system/set.
It though also seems that you can only use either the normal mode (i.e. controlling relays) or use the switch decoupled (i.e. just as virtual switch, not controlling relays), Not both.

yes, I read about “decoupled” but how to change this mode via zigbee2mqtt/FRIENDLY_NAME/system/set message exactly? I try to send different commands from MQTT.fx program to change this mode, but nothing helps(((

If i understand the z2mqtt page correctly, whereas it seems not to be super clear, you will need to send decoupled to zigbee2mqtt/FRIENDLY_NAME/system/set

Some further input I found: Home Assistant Post and zigbee2mqtt git