I have the zniffer setup as a permanent appliance… wish I’d set it up sooner! I hadn’t realized it was available for free for Silabs. I plan to post a tutorial for it once Silabs fixes their download links.

The one thing I haven’t made sense of yet is how to capture everything in the zniffer that the controller is seeing. The source of all packets received are either from the controller or devices that are close by, but I see the ACKs from the controller to devices all over the house. The only way to ensure the traffic from a particular device is captured, I’ve had to use a tablet to bring the zniffer close to the device. I’m considering operating on the antenna, but I’m a bit baffled as to how the controller is receiving the packets but not the zniffer.

ACKs and ACKs

You are now looking at a whole new level and you have several levels of communication going on.

Do you want some links to some docs?

For the ACK you see in openHAB INS12350 serial coms

for those you are seeing in zniffer I think INS13954 is probably the most penetrable. Send Data is a good one to track through and see all of the retries on retries when you turn a node off.

If you want to see the next layer down


you may be amused that wireless communication gets a random backoff after collisions of between 10 and 40 but as the clock on the 500 and before is only in 10 increments that only gives a few options. So yes random choice of a very finite set of backoffs after a collision.

So even at that level you get a couple of retries on failure. So lots of retries and lots of layers of ACKs

I’m interested in doing this; created an account @ https://www.silabs.com/products/development-tools/software/z-wave then downloaded the manuals for it. It won’t let me download the software though; it says

"You do not have the level of access necessary to perform the operation you requested. Please contact the owner of the record or your administrator if access is necessary. For more information, see [Insufficient Privileges Errors] " - looks as if it back ending into a salesforce.com site.

Any advise in how to get this software?

Best, Jay

As I said, the links are broken on the Silabs site and I will post a tutorial when they are back up. Until then, you could try opening a case with Silabs support. If you’re logged in, you might be able to see mine, which has Zniffer and PC Programmer attached to it.

Almost forgot… if you download Simplicity Studio (that link works), you can install Zniffer and PC Controller through it, but it does not include the zniffer firmware or PC Programmer to flash it with. But if you have the firmware flashed already, then you can at least get Zniffer installed.


These links still work

and firmware is in


No they don’t… that’s the problem. Support said they are working on it.

In that case they have been supper speedy or they only work for me as I am approved. Could you try again?

I did before replying and several times earlier today. You’re permissions must be different after purchasing the dev kit.

I think you hit it on the head. Not sure if that is intentional or just a mistake. Would be sad if it all disappeared into a closed world again.

I didn’t purchase anything; maybe that’s the issue?

Best, Jay

@5iver @robmac @jwiseman

Please see the post #28 in this topic: New UZB dongle, Z-Wave PC controller immediately exits (or crashes) with no error message

After you’ve accepted the licence agreement you will be able to download almost everything.
The Zniffer could also be downloaded then.

I think that is what @5iver is saying. It did work but they have broken it and made it locked down.

Anyway we have drifted this this thread into yet more directions. It was about full network heal. Possibly this is another post.

Thank youm but I tried that 17 days ago, but it didn’t help. Still doesn’t work for me… multiple browsers and no blocking. Silabs support confirmed the issue.

Very strange. I was able to download it with the steps I wrote. And on the same day it brokes?

Different countries & perhaps different servers? Especially if a CDN or cloud service is involved.

You could also try to install Simplicity Studio 4


There are all z-wave tools included.
Once you’ve installed it, go to tools --> z-wave --> “PC Controller” and “Zniffer”
I don’t remember the exact steps. But I was able to install them both.


@rlkoshak, I derailed this topic. Could you please move our Zniffer posts to a new topic starting from Z-Wave Network Heal.. when is it needed? does it always need to happen??

1 Like

Sorry, I missed that… :smile:

I’d love to but I’ve not the slightest idea how. I thought there would be an option in the admin settings but there is nothing relevant there. @mstormi, I think you did this on the “What I made with pictures” thread. What am I not seeing?