Zooz ZSE01 Wave Unknown Device

Hello @chris,
I have a Zwave siren that isn’t yet configured in the database and appears as unknown device. The Model is ZSE01 from Zooz. Can it be added up to the database? Do let me know if further information is required.

BR,
Mammes

Please see the database guide for information on how to add a device to the database…

If you have any questions, just ask here where there are a few people who should be able to help you.

I am new to openhab and actually went through the database guide before creating this thread. I however couldn’t figure out where to locate the xml file nor where to upload the xml file to if located. The interface I have does not show the “tools” button indicated in the instructions, thus the reason for creating the thread. Snapshot of my interface attached. Also attached in the attributes of the device I am trying to add up. Need assistance to get past this stage.!


You should be able to find it in userdata/zwave. The location of userdata will depend on the type of install you have. https://www.openhab.org/docs/installation/linux.html#installation

Did you request access, get a response from Chris, and login? After your access has been setup and you’re logged in, you should see more options.

I found a user in the database system with the same name as your user here, so I guess that’s you, and I’ve given you access…

Hello Chris,
Apologies for the delayed feedback.

Yes this is my account and I have added up the device only that I am facing these errors as shown in the snapshot prior to approval. How can I get these resolved?

These errors will be removed when the information is added to the database. It should take 5 minutes to copy the data from the device manual and add it to the database.

Thanks Chris.
I can see the device has been successfully added to the database, however, I still have it showing as unknown device. I have tried the inclusion process over and over again but still come up the same. Any further steps to take after this?

First the errors need to be removed before it can be approved. Then the device needs to be exported from the database into the binding, then you need to update to the latest version of the binding…

Then it will be detected :wink: .

Aha, I keep learning new things everyday. Thanks for sharing the process. :smiley:

If I am not wrong, I believe this is your bit to do.
And will I be notified when all is done and dusted so I could update to the latest version of the binding?

Well, someone needs to do it, but if I need to add all the data to the database, then I would spend most of my free time just doing the database. I already spend a few hours every week maintaining the database, so it’s really appreciated if others can add the data to the devices they use.

No - it is up to you to keep an eye on the PRs that go in to Github. Normally I try and do a database update once or twice a week, so normally waiting this time should be ok.

I added the association group (no details in manual, but it is zwave plus, so should have lifeline). The manual leads me to believe there should be other groups though. I also added in the other missing pieces, so this device should be ready for export. Please review/modify my changes.

Thanks Scott. I have seen the updates made and all errors cleared.

Chris I guess it’s at the approval stage now. So with the approvals, exports into binding and the version updates, are these tasks anyone in the forum can do? I figured these are administrative tasks.

Thanks both.

Yes - I will try and do this tonight, otherwise it will likely be Friday as I’m travelling over the next few days.

I’ve updated the binding so hopefully this should be supported.

Thanks @chris. I however still have it showing as “Unknown Device” .

I have uninstalled the zwave binding in Habmin and reinstalled it for the third time now. I have also excluded the device from the network and set it up for inclusion and it still shows same. Is there something I am missing?

Which version of OH are you running? TMK, if you have an apt-get install but are not on a snapshot build, you won’t get an updated binding by reinstalling a binding. You can confirm you are running the latest (should have today’s date) by running this in the Karaf console…

list |grep -i zwave

Hello Scott,

Forgive my ignorance but seems I have a long way to go in understanding these concepts. Documentations are not very detailed on some issues to help with the knowledge build so I am forced to rely a lot on the discussions in the forums to understand some of these concept.

I did the automated/package installation of openhab on an RPi and is just going through the documentations of Karaf to understand and to get Karaf installed so not sure what you mean by “snapshot build”.

I however believe I am running the openhab version “openHAB 2.3.0-1”. This is what shows in the terminal window when I ssh into the Pi.

You are on the stable release. To get the database updates that Chris pushes to the binding, you must upgrade to the snapshot build of openHABian. You can do this through the console.

sudo openhabian-config

Choose to switch to the snapshot version of openHAB (If I remember right it’s option 3). Follow the on screen prompts. Now every time that a database update is pushed that you need, you can just

sudo apt-get update && sudo apt-get upgrade
1 Like

Great. Will do this and feedback. Any place to find the documentations on this?