Zooz zse40 v2 4-in-1 sensor - motion detector - arrgghh!


I have a ZOOZ ZSE40 V2 4-IN-1 SENSOR and 3 out of the 4 sensors work great. I thought my motion sensor wasn’t working because it NEVER detected motion. As in, I’ve never seen any motion detected when I look at the graph via the analyzer in Open Hab.

Yesterday I decided to unlink & remove all channels and delete the thing (4-in-1 sensor) and then re-add it to openhab. (I did not ‘exclude’ the 4-in-1 sensor from the z-wave stick and then re-add to the z-wave stick - this was my next step if deleting and re-adding didn’t work). When I got the 4-in-1 sensor back up in openhab I made a channel for motion and still saw zero motion detected. I upped the 4-in-1 motion parameter sensitivity to ‘1’ which the Zooz manual says is the “most sensitive setting”. Still nothing. I finally manually “woke up” the Zooz 4-in-1 sensor (inserting a paper clip into the tiny hole on the Zooz 4-in-1 sensor) and VOILA’! MOTION DETETED!! But…that is the first and last time I’ve seen motion detected. I checked the analyzer and it showed motion was detected at the time I woke up the sensor. So at the very least I know the motion sensor is working (maybe “not broken” would be slightly more accurate?). From this point on I just moved in front of it, waved my hands, etc. I don’t have it permanently attached anywhere, so I moved it to the bathroom knowing it’ll sit there for hours with zero motion and then when the lights come up and I walk in it should easily be able to detect motion for the first time in hours. Still nothing. Even today, still zero motion detected over the past 15 hours or so. The 4-in-1 sensor detected all the times the lights when on and off though (like 5 times), so that at least tells me the 4-in-1 sensor is active.

So, it seems like the 4-in-1 sensor has to be “awake” 100% of the time to detect motion? If this is true, I do not know how to make it stay awake all the time. From reading the manual it seems like this is not how it’s supposed to work because it will drain the battery faster. But maybe not and I’m totally thinking wrong here? (which, thinking wrong is my forte, lol)

Here’s my goal: I’m trying to turn on lights when the 4-in-1 sensor detects motion. This seems pretty common by reading the OH forums and reading around the internet. If anybody can please help steer me in the right direction on how to get my 4-in-1 sensor to detect motion 24/7 I would greatly appreciate it!! :slight_smile:

Thanks so much!

Your battery-powered motion detector doesn’t need to wake up to the Z-wave controller in order to detect motion. It is a “Reporting Sleeping Slave” that only needs to wake up to receive messages from the controller, but it can send reports to the controller (e.g, of motion) all the time. I’m just shooting in the dark, but have you confirmed the device is fully initialized and the XML is present?

Hello jstro!

Thanks for your reply! Much appreciated! :sunglasses:

Well, I’m pretty sure the device is fully initialized, but I don’t know how to 100% know. I did some research on logging/debugging/etc which I’ll explain in a second. All the “Thing>Properties” in Openhab are filled with text that looks good to me. Each sensor is reporting (even the motion detector - it just doesn’t report any motion). The temp channel says 70 degrees, the humidity channel says 60, luminance says 100 (overhead light is on), Motion says OK, and the Alarm (tamper) [Deprecated] says NULL. For the last one (Alarm (tamper) [Deprecated]) I’m assuming it says “NULL” because the Zooz Manual says “Tamper switch is located to the left of the battery slot. It’s activated whenever the sensor’s cover is removed while the device is powered up. It will send an alarm notification as scheduled”, but please let me know if I’m wrong. :slight_smile: The sensors all update (like the change in degrees, the luminance, etc). Sans the motion which always says OK and the Alarm/Tamper which always says NULL).

For debugging/logging I SSH’d into the Karaf console and looked for debug logs for zwave, but nothing came back. Typed in “log:set DEBUG org.openhab.binding.zwave” and the Karaf console reported nothing. No “command not found” or data or anything. The cursor just went to a new command line. I typed in log:display and got back a giant list of info though. Nothing that was really helpful, but it was at least interesting. It was just stuff like ‘item state changes’ and ‘channel trigger events’ and more. I read some stuff on changing the “logging detail” (log weight like 200, 300, etc), so I need to read up more on that and the whole logging thing.

As for the XML file being present I honestly have no idea where to look. I SHH’d back into the Karaf console and tried searching for ‘/usr/share/openhab’ but got a ‘command not found’ response. I might need to do more research here.

Thanks again jstro!


Well it sounds like it is fully initialized since you’re getting the other sensor reports. You can find your XML in the userdata/zwave directory. If you go to your Things and pull up your Zoos sensor thing, you’ll see at the top (right under “status”) if the controller is waiting for initialization from the device.

It’s certainly possible the unit is defective. The led should flash red when it detects motion. Do you ever see it flash?

Quick Update - I took the back cover off (battery cover) to test the tamper alarm and by golly the analyzer in openhab changed from ‘NULL’ to ‘ALARM’! YEA! Now I’ve got confirmation that the alarm/tamper sensor is working too! Oddly though, once I put the battery cover back on, the openhab analyzer changed from “ALARM” to “OK” (not “NULL”). One one hand that’s great (changing from ALARM to OK), but also odd because it had been showing NULL for as long as I’ve had it (about a year maybe?).

Unfortunately though, during that whole ordeal of walking in front of the sensor, waving my hands in front of the sensor, and picking it up and taking the battery cover off…no motion was ever detected. Darn it.

I’m at least a tiny bit further in figuring this out, lol! Thanks again!


Awesome thank you again jstro! I’m not sure how to get to that directory because I’m not very familiar with Linux, so I need to read up more on that.

I never see it flash, unfortunately (unless I hit the manual wake up button - it will light up then). (I’ve ever only seen it flash on it’s own once and that was yesterday when I manually woke it up and it detected motion). I do have ‘Parameter 7’ for the 4-in-1 sensor set to mode 4 (motion indicated with flashing light) and I watch for the light to blink every time I go near the thing, lol.

Thanks again jstro!


Well, darn. It sounds like following up with Zooz on why it’s not flashing/detecting motion might be the next step. Others here might have some better ideas though. Good luck. This unit does seem to get good reviews.

Hi again! :slight_smile:

I contacted Zooz and they asked me to get a brand new battery to see if that is the reason it isn’t detecting motion b/c I had done all other stuff to try and get the sensor operating.

So, I got a brand new battery and installed it today and did a factory reset again. I got it back up in Openhab and it shows “online” in Openhab. Unfortunately, the 4-in-1 sensor now comes up as an unknown device and doesn’t have any channels - I’m wondering if this is a result of the factory reset? Anyway, the 4-in-1 sensor with a fresh battery and a fresh factory reset (I also excluded the device before the factory reset, and then re-included the device after factory reset) shows up as online in OpenHab, but it doesn’t have any channels and the ‘thing type’ says “This device has not been fully discovered by the binding. There are a few possible reasons for this -: The device is not in the database.The device initialisation is not complete.”. Here’s the whole thing:

  • This device has not been fully discovered by the binding. There are a few possible reasons for this -:
    • The device is not in the database. If the device attributes show that this device has a valid manufacturer ID, device ID and type, then this is likely the case (eg. you see a label like “Z-Wave node 1 (0082:6015:020D::2.0)”). Even if the device appears to be in the database, some manufacturers use multiple sets of references for different regions or versions, and your device references may not be in the database. In either case, the database must be updated and you should raise an issue to get this addressed.
    • The device initialisation is not complete. Once the device is included into the network, the binding must interrogate it to find out what type of device it is. One part of this process is to get the manufacturer information required to identify the device, and until this is done, the device will remain unknown. For mains powered devices, this will occur quickly, however for battery devices the device must be woken up a number of times to allow the discovery phase to complete. This must be performed with the device close to the controller.

jstro had mentioned earlier about the xml file, so I started trying to figure that out. I SSH’d in Openhab and could not figure anything out. I did lots and lots of reading the internet. Finally I came across Samba! Got that set up and now I can access the openhab files through windows. YEA! I found the user/zwave directory via Samba and there is not an XML file for the 4-in-1 sensor! YEA!? I think? :slightly_smiling_face: (The other z-wave devices I have do appear in user/zwave directory).

So, is that what I’m missing? The xml file for the 4-in-1 sensor? I did a tiny bit of research on that and came upon the zwave device database (OpenSmartHouse Z-Wave Device Database), but did not find an xml file to grab. Any help in the right direction sure would be greatly appreciated! Thanks so much!

Have a great rest of the day,

Very likely. Need to do the manual wakeup several times. Could help to put Zwave in Debug mode to see where you are in the initialization.


OH! Holy Smokes! Nevermind about the xml file. :blush:

I hit the zwave button a bunch of times on the 4-in-1 sensor after writing up that big long reply to wake it up and low and behold the xml file got created! It has channels and looks like what I’m used to. I should know better… I should have done the easy thing first before trying to figure out the hard thing, lol.

Well, now it’s time to see if it’ll detect motion! Wish me luck! :smiley:


Awesome Thank You apella12! You were right, that’s what it needed. I must have been typing when you were responding with helping me. Thank You so much!

I’ve read a little about debug mode, so I’ll look more into that. :slight_smile: Thanks!

Have a good day!

Good luck on the motion detection :smiley: