Zulu java performance problems with rrd4j charts on raspberry pi 3

Hi

I’m in the process of updating from OH 2.1 to OH 2.2 and also moving from a Pi2 to a Pi3. I also took the opportunity to switch to Debian Stretch and try Zulu java.

Everything seemed to be working OK except that I noticed my one hour rrd4j chart image wasn’t displaying in the android app. Looking in the OH log the request for the image was being timed out. When I tried the URL directly in a browser it was taking over 30 seconds to return the image.

Since I couldn’t spot any rrd4j related changes in OH 2.2 I thought I’d try switching back to using Oracle java and the problem was solved. With Oracle java the URL image is displayed instantly.

I also noticed looking at the timings in the logs that my Cron based rules fire about 300ms closer to the expected time when using Oracle java.

Has anyone else noticed performance issues when using Zulu?

At least as a few months ago, Zulu was known to perform better on ARM processors. Are you running on an ARM? If not, I can easily see that Zulu might not be as performant as Oracle.

No one has reported any performance problems like this to the forum to my memory.

Hi,

had a similiar issue a few days ago.

After my sd card died last week I decided to go for an CentOS7 installation on my Raspberry Pi 3B.

Using openjdk available from the repository lead openhab2 (latest snapshot) to be unbelievably slow. Starting up took more than 15 minutes and watching the log was like „oh, system seems to be frozen“. After startup, I found things working except the charts. (I also use rrd4j for persistence.)

After replacing openjdk with Oracle Java, openhab immediately started to run smoothly. Everything is fast again and charts are also displayed at an acceptable speed…

No idea why there was such a huge difference between the two jdks…

I will stick with Oracle for the moment, therefore…

Please don’t mix up OpenJDK and Zulu JDK.
OpenJDK has never been recommended to be used on ARM with openHAB, while Zulu is normally working smoothly.

1 Like

Good to know!

Didn‘t knew this until now… :-o …

I tried to add the Zulu repository at the very beginning of my installation. However it wasn‘t able to find the data for the arm architecture… doing some research lead me to the understandig that openjdk and zulu are the same :frowning: .

However it I didn‘t recognize the difference mentioned in the installation manual.