ZW132 Aeotec Dual Nano parameter 247 missing

I have 4 x ZW132 dual nano switches and I cant see parameter 247 in Habmin. The ZW132s are firmware 1.2, 2,1 and 2.2. I understand P247 should be available from FW 2.0 onwards. I have tried excluding and including the 2.X versions but still no P247.
Im looking for this parameters to make the 2 way switch stay in sync rather than toggle the output.

Any suggestion welcome
Thanks

Let’ start with the basics and get information on that Thing. we need more details.
Post the Habmin output from Configuration -> Things -> [your thing] -> Attributes.

Thanks Bruce
Attributes of the 2.1 FW switch

The last few parameters

I think I see the issue but I want condirmation from @sihui or @chris first. I think it is an error in the device database. The range should be 0 to 3, I believe.

Entry: https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/1017

Correct.

Thanks
But even if the range is wrong, should that stop the parameter from being visible in Habmin? Checking the link above to the database there are other parameters (120,121,144 for example) that have range 0 to 0 and they are visible in Habmin

First thing to do before further guessing is: please update to the latest 2.5 snapshot zwave binding, remove the Thing (don’t exclude!), readd the Thing, test again.
https://ci.openhab.org/job/openHAB2-Bundles/org.openhab.addons.bundles$org.openhab.binding.zwave/

@sihui do we want to try and build a fixed version or wait to see how the binding reacts? That device is a real mess and has a LOT if configuration parameters.
I think @chris may wish to add an automated check to catch when option values exceed the range. Ideally a check would be run to flag existing devices that violate this rule.

Best option is to fix obvious errors.
(I’m not available until tomorrow :grinning:)

I may not be able to do it until this evening. It looks like most of the configuration parameters have incorrect range and the numbering goes to 255. Can try to start tackling it this weekend.

BTW, what are the icons on the upper left when logged in at cd-Jackson?

This is not so easy if I remember correctly - I used to have that, but I then have errors when (for example) 255 is required, and the range is otherwise less. If I recall, I removed this check for this reason.

They just take you to different parts of the screen, or the top one takes you back to the list.

1 Like

Thanks, chris.

You agree that devices like this are problems waiting to happen, right? Would it be a lot of work to run a check against the database & generate a listing of devices to be manually reviewed or repaired? Perhaps just a check for range 0-0 or that range with options listed.

It would be a big review job but would help us make things even more stable by fixing obvious errors like this.

I’d not read through this fully when I replied above…

I agree with @kiwi - the allowable range will not stop the parameter showing up in HABmin. @kiwi what version of the binding are you using? If you are not using the snapshot, I think this device is not included since this 2.5 was released in December, 2.5M1 was released in January, and this device was added to the database on the 25th February.

So, if you’re not on the snapshot build, you must have one of the above builds, and the device is not included and that is likely the problem.

1 Like

Im using 2.4.0 on a completely standard build.
I tried installing the 2.5 snapshot using this process
Unistall 2.4 via paperui
Copy .jar to addons
restart OH

Came up with this error

So Ive just put it back to standard by reversing the above. At least it work 95%. I don’t understand Chris’s comment above as Ive had these devices for a least a year and they’re included and running fine apart from the physical switch acting as a toggle (hence the need for param 247). SO it must have picked something up from the database.

This is the device that I excluded and re-included the other day a part of my test

Your zwave binding is not working. You need to upgrade to the latest 2.5 snapshot (again!):

If you encounter errors see this posts:



For the latter one you could also install the Serial binding to get the dependencies.

Fixed for both firmware versions.

Upgraded to zwave 2.5 snapshot binding, removed and re added device and now p247 is available :smiley:
Thanks to everyone

1 Like

Yes, but the older binding didn’t have the new database entry with P247 that you are trying to get working. The old binding probably just had a single entry for this device.

In any case, early this year the entries were split to separate out the versions and this was not available in 2.4.

1 Like