ZWave Aeotec Stick not found

I’m trying to get an Aeotec USB serial stick to be recognized. It always says “Status: OFFLINE - COMMUNICATION_ERROR zwave.thingstate.serial_notfound”. I know I the serial port is com3, and to prove it I wrote a short program that opens the stick and does an interrogate over the serial port. That works. But the Z-Wave Serial Controller is never recognized. I haven’t paired the controller with any zwave light switches yet, but it should see the controller, right?

Here is the console:
17:21:28.554 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Connecting to serial port 'com3’
17:21:28.559 [INFO ] [smarthome.event.ThingUpdatedEvent ] - Thing ‘zwave:serial_zstick:52da4562’ has been updated.
17:21:28.560 [INFO ] [me.event.ThingStatusInfoChangedEvent] - ‘zwave:serial_zstick:52da4562’ changed from OFFLINE (COMMUNICATION_ERROR): zwave.thingstate.serial_notfound to OFFLINE (BRIDGE_OFFLINE): Controller is offline
17:21:28.771 [INFO ] [me.event.ThingStatusInfoChangedEvent] - ‘zwave:serial_zstick:52da4562’ changed from OFFLINE (BRIDGE_OFFLINE): Controller is offline to OFFLINE (COMMUNICATION_ERROR): zwave.thingstate.serial_notfound

Sorry, I’m running on Windows 10 with openHAB 2.1.0

Have you downloaded and installed the drivers for the stick?

The drivers are not necessary, It looks like a standard USB serial port. Given that I talk to it with my own program, this is not the issue.

The device would not work correctly in my two windows installations without the drivers.

Have you checked the permissions on the serial device? I’m running openhab on linux and I’m using a Aeostick. I had the exact same problem. I solved it by setting permission on the usb device so that anyone can access it.

Not sure how this works on windows though?



I downloaded the driver and restarted openhab but still no joy.

Switching to OH 2.2.0 fixed it.

Hi, how can i set the user permission for the Zwave Stick?