Zwave - Aeotec ZW056 Door Chime Channels

I found a couple of threads in which users were attempting to add Channels to the Aeotec ZW056 Door Chime but they are several months old and not clear how it ended. I’d like to know if anyone is using this device and seeing more than the 3 original channels. My use requires that I be able to change the chime type dynamically, and that doesn’t seem to be implemented in any of the code I downloaded (only Switch, Volume, and Repetitions appear), even though additional Channels appear to be added in the device database on (including parameter “6” which I need). I tried 2.1, 2.2 snapshot, and both versions with the development .jar files replacing the standard Zwave binding. Only the 3 channels appear. In addition, I’m having a problem linking Items to the Volume and Repetitions Channels (even auto-generated Items), and suspect the Channels have an invalid or unsupported type (“decimal”). They seem to link when I change “decimal” to “number” in the …Thing.json file, but not a solution I would want and the device still seems to have problems. FYI, I am using the Aeotec USB stick controller and I am testing this on Windows. Any suggestions would be appreciated.

I currently use this and would like the additional channels listed in the channels to appear (ZW056). I’ve recently been trying to compile this and figure out why it doesn’t work but it looks like it should. I had this functionality in OH1 and I miss it. I’ve recently asked @chris for some thoughts on this but I don’t want to bug him. It’s good to see others want this functionality as well. Maybe Chris will chime in.

What do you mean by “appear” - are they not even listed in the channel list? In the message from @cbutler there is talk about 3 channels. Can you please be clear about what is, and what isn’t available?

As far as I remember, other people are using the config_decimal channel successfully on other devices, and there is a test for this in the binding, so I think it should work ok. If not I have this device here somewhere I think so I could try and test it, but it won’t be for a few days as I’ve other things to look at first.

I think you are probably right though that the item is a number.

Here is what is in the database:

and here is what I see in habmin:

I would like to see the ‘Play Chime Now’, ‘Doorbell Notifications’, and ‘Button Battery Status’ show up in habmin to link items to them.

You said you think that they are numbers, would that change the xml file to config_number? I have the device and the dev environment setup so I am more than willing to learn and test this but I need some guidance.

Thanks for your time.

All, thanks for the responses.
I’m back to released Version 2.1 for this test. As might be expected, the others have additional quirks, but Channels and channel linking for this device act similarly across all versions I tested.

To answer your question, only 3 Channels are shown in the Channel list. Here is a paste from Paper UI:

Note that type of Volume and Repititions is Decimal
When I link the Volume or Repitions Channels to an Item, “Some Error Occurred” flashes in the lower right corner instead of the normal success message. I tried the “Create New Item” feature as well as trying to create my own item in a.items file, in case my .items syntax had errors.

I also saw an interesting warning message in the openhab.log file when I attempted to to link those two channels.

2017-11-11 12:52:11.241 [WARN ] [] - Received HTTP PUT request at ‘items/ZWaveNode16_Parameter’ with an invalid item type ‘Decimal’.
Node 16 is the ZW056.
There’s a line in the file: org.eclipse.smarthome.core.thing.Thing.json

      "acceptedItemType": "Decimal",

for Volume and Repititions

If I change “Decimal” in the file to “Number” and restart OpenHAB, then the Decimal in the display is now Number and I can link the Channel to an Item successfully and no new warning is added to the log file.

Also, there are only 3 channels for this Thing in the Thing.json file.

The parameter edit in Paper UI also doesn’t work as expected for this device. When I click the blue edit icon, the parameters appear on the screen as well as the white check mark in the blue circle (as expected), but then the white check mark turns black. I can change parameter values on the screen, but nothing happens when I click the blue circle with the now-black check mark. OpenHAB2 also appends a warning in the log file when I attempt to edit parameters, and at other times (I believe when the Thing is opened).
2017-11-11 13:27:03.122 [WARN ] [] - Cannot find channel type: zwave:aeon_zw056_00_000_config_decimal_param6
Another observation is that this device does not appear in the Control window of Paper UI until all 3 Channels are successfully linked, but other devices appear after the first Channel is successfully linked. Interestingly, it does appear in the Classic UI when only the Switch is linked, and the switch works.

Let me know what else you may need. Thanks