Zwave Aeotec ZW175 channel mapping?

  • Platform information:
    • Hardware: Raspberry PI 4, 8GB
    • OS: Linux openhabian 5.10.17-v7l+ #1403
    • Java Runtime Environment: OpenJDK Runtime Environment Zulu11.45+27-CA (build 11.0.10+9-LTS)
    • openHAB version: openHAB 3.0.1

I have a Aeotec ZW175 switch (operating my subwoofer) connected to Openhab via a Aeon Labs USB Z-Wave Plus Controller.

My .things file is:
Bridge zwave:serial_zstick:32208706ae “Z-Wave Serial Controller” @ “B39BMK” [ port="/dev/ttyACM0", controller_softreset=“false”, controller_master=“true”, heal_enable=“true”, security_networkkey=“XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX XX”, security_inclusionmode=0, controller_sisnode=1, controller_sync=“false”, inclusion_mode=2, controller_wakeupperiod=3600, heal_time=2, controller_exclude=“false”, controller_inclusiontimeout=30, controller_hardreset=“false” ]
aeotec_zw175_00_000 subwoofer “Z-Wave Node 017: ZW175 Smart Switch 7 Subwoofer” @ “B39BJO” [ node_id=17 ]

My .items file is made from the Openhab channel interface (I removed the irrelevant points):
Group Subwoofer “Subwoofer Group” (B39BJO) [“Equipment”]
// Points:
Switch ZWaveNode017ZW175SmartSwitch7Subwoofer_Switch “Subwoofer” (Subwoofer) [“Point”] { channel=“zwave:aeotec_zw175_00_000:32208706ae:subwoofer:switch_binary”, homekit=“Switchable” , ga=“Switch”}
Number ZWaveNode017ZW175SmartSwitch7Subwoofer_Electricmeteramps “Electric meter (amps)” (Subwoofer) [“Point”] { channel=“zwave:aeotec_zw175_00_000:32208706ae:subwoofer:meter_current” }
Number ZWaveNode017ZW175SmartSwitch7Subwoofer_ElectricmeterkWh “Subwoofer Energy meter (kWh)” (Subwoofer) [“Point”] { channel=“zwave:aeotec_zw175_00_000:32208706ae:subwoofer:meter_kwh” }
Number ZWaveNode017ZW175SmartSwitch7Subwoofer_Electricmeterwatts “Subwoofer Power meter (watts)” (Subwoofer) [“Point”] { channel=“zwave:aeotec_zw175_00_000:32208706ae:subwoofer:meter_watts” }
Number ZWaveNode017ZW175SmartSwitch7Subwoofer_Electricmetervolts “Electric meter (volts)” (Subwoofer) [“Point”] { channel=“zwave:aeotec_zw175_00_000:32208706ae:subwoofer:meter_voltage” }

When I look at the data that comes out of the items it seems like the data for the energy measurement is mixed up with the voltage (local voltage ~230V). and the voltage and current are empty.

Does this issue sound familiar, anyone else experience a similar issue (the energy- and voltage reading of this switch mix up)?

I have 2nd identical switch and a Aeotec nano switch ZW116 with the exact same issue.


It is not recommended to use a text file to define Z-Wave Things due to the high change of errors. Many people configure the Thing in the UI and then configure Items & Rules using files.


Thanks for the advice. I have also Z-Wave rollershutters in my .things file, which require a channel parameter to invert the %, i.e. config_invert_percent:
Thing philio_pan08_00_000 rollershutter “Z-Wave Node 019: PAN08 Rollershutter” @ “B39BJO” [ node_id=19 ]{
Type blinds_control : blinds_control [config_invert_percent=true ]

I haven’t been able to find this setting in the things UI, therefore I switched to .things file.

Nevertheless, I will give the things config for the switch a try via the UI and keep you updated.

It appears that option is not in the device firmware. @chris this might be a good advanced option for some people. It appears to me they still need to use text files currently.

By the way Bruce, do you advise to also setup the bridge via the UI or just the things?

What do you mean by the bridge? The controller? I set up all Things from the UI if possible. I currently have everything else in text files. That was my personal choice at that time.

Yep, I mean the controller. It is the 1st line in my .things file and referred to as “Bridge zwave:serial_zstick…”.

1 Like

This option is in the binding, but should be configurable in the channel options in the UI. I can’t really test this myself at the moment, but I thought that channel configuration was provided in the UI.

1 Like