Zwave Aeotec ZWA005 device misconfig ? No informations, just -NaN

Hi there,
I am currently starting my setup with openhab, here are the informations about my config :

  • Platform information:
    • Hardware: Intel Core i5 Mobile / 12Gb Ram / SSD
    • OS: Debian Buster
    • Java Runtime Environment:build 11.0.6+10-post-Debian-1deb10u1
    • openHAB version: 2.5.3

I have a Z-Wave Serial Controller Eversping SA413 and two devices :

  • DWS01 Door and Window Sensor
  • Aeotec ZWA005 Motion, light, and temperature sensor

The two devices are correctly detected and installed on my setup. The DWS01 is working out of the box. I mean when I open or close the device, informations for open or close state appears instantly on paper UI.

I just configured the ZWA005 to get temperature every 1800sec, and poll device every 3600 from controler without success. When I check at Control tab and expect to get temperature information, or motion data, I just get -Nan informations.


I seriously think that I did a misconfiguration but, the fact is, I am currently a fuc***g noob. I tried to read logs, I tried to manually poll device with openhab-cli without success.

Anybody should have advice to trig data, check for specific log or anything else ?


Welcome to the OpenHAB community, great first post!
Do you use Habmin user interface? If not you may want to try it because it has some useful tools for zwave. First thing to try is setting the zwave logging to debug. Here is how

Once you get logging in debug mode try excluding and reincluding the device using Habmin while the log is in debug mode. Post log here (use code fences, don’t filter the log)

1 Like

I guess ZWA005 is a battery operated device.

Sometimes the device may not be fully initialised. So, as @Andrew_Rowe suggested enable z wave logging, and then try to wake up the device. Easiest way would be to press the inclusion button and monitor the logs.

Once it is fully initialised, you can make changes and wake the devices so it can respond to the changes.

1 Like

Thanks to all of you. I will give a try today by enabling debug and trying with habmin !

See you !


I just enabled logs and try with habmin to delete device and add again. Logs are very verbose, I prefered to paste them on pastebin.
Here are the exclude logs :
Here are the include logs (more verbose) :

Thanks for help !

[EDIT] 4 minutes after I added the device, I get these lines in debug log

2020-04-19 15:34:47.454 [DEBUG] [rg.openhab.binding.zwave.handler.ZWaveThingHandler] - NODE 5: Polling...
2020-04-19 15:34:47.455 [DEBUG] [rg.openhab.binding.zwave.handler.ZWaveThingHandler] - NODE 5: Polling deferred until initialisation complete

You need to keep waking up that battery device until discovery is complete. Sometimes deleting (NOT exclude) & re-adding the Thing in HABmin helps. I usually find the HABmin device status is sometimes a good clue. I expect you are seeing it stuck in REQUEST_NIF which means the binding requested the device to send its details but they have not been fully received yet.

Allright, everything is working now.
As I read this topic : Waking device to complete discovery results in node going offline (COMMUNICATION_ERROR)
Then I tried to keep the device waked up by pushing (one time) the button.

Despite that the doc talks about pushing the button for 2 seconds, it appears that the red led comes on but the binding does not receive any informations whereas that pushing one time (2 or 3 times) makes the device working as expected.

Maybe that this solution could be integrated in the kb for this device, it will avoid people to be stuck in my position in the future :slight_smile:

1 Like