Zwave: alarm_raw disappears from binding (YRD446 lock)

For this lock, I was using the org.openhab.binding.zwave_2.3.0.201806302134.jar dev binding for almost a month, and all of a sudden, I stopped getting notifications from it (when the door is locked and unlocked for example). alarm_raw doesn’t appear as part of the binding anymore. I tried using the latest dev snapshot 2.4 downloaded today, but I still don’t see this in the binding. The polled values like the battery level and the switches like lock/unlock work fine. I was wondering if anyone had any ideas on how to fix it, short of removing and re-adding it?

I’m not sure why it would have changed. The channel is certainly still listed in the database and it seems there have been no changes to this device since it was added in March.

The only thing I can think of is that for some reason this has been deleted from your json database which stores the configuration (the thing definition is only read once, so if it gets changed somehow, it will not be reset). You can try to delete the thing and add it back. Excluding and re-including will not help any more than just deleting the thing. This will cause it to re-read the thing definition from the database.

Thanks Chris, I did that but it didn’t work. Just to be clear, the events stopped on the older version of the dev binding, for apparently no reason, and I tried the latest version to see if that fixed it.
My last event was:

events.log.4:2018-07-20 08:12:46.989 [vent.ItemStateChangedEvent] - zwave_device_2a2bd030_node5_alarm_raw changed from {“notification”:“ACCESS_CONTROL__MANUAL_LOCK”,“level”:“1”,“type”:“ACCESS_CONTROL”,“event”:“1”,“status”:“255”} to {“notification”:“ACCESS_CONTROL__REMOTE_LOCK”,“level”:“1”,“type”:“ACCESS_CONTROL”,“event”:“3”,“status”:“255”}

and then nothing after that. What’s strange is nothing changed - that event is from when I went work and locked the door, and I never modified openhab afterwards. It just stopped reporting events.

I have a zwave HEM that reports periodically, so I know events are coming in. I was just curious if anyone had seen this problem with the locks, or if there was a quick way to reset things. I can always try excluding it, resetting the lock to factory, and reincluding. I already pulled the batteries and restarted the lock but it didn’t change anything. The polled values for battery work fine, and the lock command itself works, so it’s not a big deal - although I did have an automation to disable the alarm system upon unlock, which I can do without.

Thanks for the idea though.

Just to clarify, you said -:

Does this mean that the channel is not even listed in the UI? I’m just asking as you also say “the events stopped on the older version” - so I’m wondering if the channel is still showing in the UI, but it’s not being updated?

I read “alarm_raw dissappears” as if the channel is no longer in the UI, but maybe I misinterpreted?

If the channel is still there, but it’s just events that have stopped, then it might be that the associations have been removed. You could try to “reinitialise” the device - there’s an option in the menu in HABmin to do this (select the thing, then in the menu in the top right select Advanced mode, then you should see an option to reinitialise in the same menu). This will re-apply the configuration, including the associations.

Thanks Chris, re-initializing fixed it. I wonder why it stopped all of a sudden. habmin said “Node initializing: GET_CONFIGURATION” for the device for a very long time (> 10 minutes) but all is working now. It would be nice if there was a way to call it periodically from a rule I guess – not sure what caused the events to stop in the first place.

Originally I was using the June 2.3 dev binding when it stopped reporting alarm_raw, so I went to the Thing in the Paper UI and unchecked alarm_raw from the Coniguration->Thing->Channels. When I tried to re-check it , Paper gave me an error saying item not found. So I delete the entire Thing, and when it was rediscovered I could add alarm_raw back to the Control area of Paper but it would never show any value. I installed the latest 2.4 dev binding with the same behavior.

But doing the reinit from habmin fixed it.

Thanks again.