ZWave and 2.4 Binding

Im posting this in the hope it saves someone else many hours of debugging!

I have four Aeotec Dual Nano switches which were working fine on 2.3. Upgraded to 2.4 and two of the switches worked properly and two “almost” worked. By almost work I mean the physical switch connected to the nano would turn it on / off as expected, I could see volts / amps and so on. However openHab would not control the switch. I spent hours looking for differences in the setup, configuration etc. Removed the device, re-included, factory reset and so on.

Finally I checked the firmware version of the nano switches. The working versions were 2.2 and the problematic ones were 1.2. Upgraded firmware to 2.1 (newest on Aeotec website) and it now all works.

So if you’ve tried all the obvious, check firmware versions and upgrade to the latest.

Hope this helps


Thank you for posting this.:smile:
I had just upgraded to OH 2.4 and my dual nano switch stopped working (the same way as you described above)
I upgraded to the switch firmware to 2.1 and all is working again.:grinning: