Zwave battery power devices

The doorlock i have is KwikSet 910 but showing up as “914TRL Touchpad Electronic Deadbolt””
i came across a similar post from last year and looks like it was fixed but i wasnt sure if any of the changes made it to the current release of openhab

I had to leave the covers off my garage door sensors until they were fully adopted, then they showed up as “ZG8101 Garage Door Tilt Sensor” and started working. The battery level took a while to appear but showed up correctly the next day.

They look like this in my items file:

Number GarageBattery5 “#5 Garage Battery” {Channel=“zwave:device:cafxxd96:node21:battery-level”}
Contact GarageDoor5 “#5 Garage Door” {Channel=“zwave:device:cafxxd96:node21:sensor_door”}

And like this in my Sitemap:

Text item=GarageDoor5 label="#5 Garage Door"
Text item=GarageBattery5 label="#5 Garage Battery [%d %%]"


Thanks Ira.

i tried a completely new setup on a windows machine with a new Zstick Gen 5 and two sensors; Remotec switch and Monoprice (vision security) ZD2102 dorr sensor. Both got recognized correctly with a green check mark and status shows online…

When i go to “control” in PaperUI, remote switch turns on and off with the switch icon toggle on the UI.

However, the door sensor only shows the state change 1st time when i bring the magnet close to it to “CLosed” - when i move the magnet away, it does not change the state to Open. Also i have it connected for a ocuple of hours but no battery value yet and when i open the case of the sensor, it does not show a tamper alarm.

on the “Z-Wave Serial Controller” i see the start frames go up by 2 every time i bring the magnet close to the sensor or move it away but the Frames Acknowledged does not increase.

Also in Habmin, under attributes security shows “?”

i am wondering if I have to set a parameter somewhere so that the Gen5 stick will only perform secure inclusions? I believe this door sensor is a Zwave plus sensor and requires a secure association.

are there any other troubleshooting steps i can perform? any log files that can shed some light on this?


Try in Paper, going to Things, selecting the problem device and choosing edit, the pencil on the right, then find the Association Groups section, the find Lifeline, set it to Controller and then press save.

I think that fixed it on mine.


Thanks, i dont see the option of Lifeline under association groups in habmin or in Paper ui.

i tried several differt things and what i have noticed is when i have the security enabled on the controller (secure inclusion mode set to “all devices”) , the sensor remains as an unknown device. There is no node file created in the zwave folder.

when i disable secure association, it seems to get fully initialized and it accpet the first state change to “closed” but there after it does not change the state. Battery and tamper do not work either.

i have attached the log files if it helps and the node file that was created with secure association disabled.

any other ideas appreciated.

under assiociation groups it shows only control command which is set to “openhab Controller”

under wake up configuration, wake up node is set to 1

node8.xml (8.2 KB)
events.xml (124.6 KB)
openhab.xml (46.3 KB)

i have renamed the events.log and openhab.log to .xml extentions for uploading here

Sorry, I picked the wrong device. My sensor only has one thing under associations, but it’s set to node_1 which I think is the same as controller. Is there a choice just called controller? Not saying “openhab Controller” is wrong, it just doesn’t exist on my setup.


No the only option i have is “openhab controller”-

would you be kind enough to include your node file so i can compare it with mine?
Also is the device you are looking at zwave plus device?

in Habmin under attributes, what does it say for security for this device?


I doubt that it requires secure inclusion. In the zwave binding, the default setting for security is just for Entry Control Devices (i.e. locks). There’s another option on the Serial Controller thing to enable security for All Devices, which is what you want if you want to securely include devices that a) are not locks and b) support security.

For your door sensor, you should put the zwave binding in debug mode, then watch the openhab.log file for activity on the node in question when you move the magnet close to and away from the device.

If you want to watch the log in real-time, something like this would do the trick (assuming you are a Linux distro).

tail -f openhab.log | grep "NODE nn"

where nn is the node number of the device.

Alternatively, you can use the zwave log viewer to view the log in a more human-readable form.

BTW, it might help if you could summarize the remaining issues you’re having. When reading through this thread, it’s a bit hard to deduce what’s still not working.

Hi Mark,

based on my observation, the issue i m having seems to be specific to battery powered Zwave plus Entrty devices that i believe require secure association.

a) Zwave garage door battery powered sensor seems to be working
b) Zwave plus door sensors do not seem to be working (they get identified correctly as ZD2102-5 Door Window Sensor but does not change status (or report battery , tamper) except for the 1st time when it changes to closed when i bring the magnet close to it)
c) Zwave plus PIR motion sensor gets recognized as ZSE40 Zooz 4-in-one motion/temperature/humidity/luminance sensor and it seems to be reporting temperature, humidity and luminance values. i havn’t seen it trigger motion yet.

I have set the controller to use secure association for “All devices” but all of them after they associate show a “?” for using security under attributes. So my take so far is I am having issue with battery powered “ZWave plus” sensors that require secure association.

of course this could be related to this specific sensor type manufactured by Monoprice / Vision Security and from what i know they require secure association

if you are in the US, i would be more than happy to ship out one of these door sensors. They work very reliable with my other Openremote based controller. When i look at the node file that is generated with Openremote, they all have secure mode.

i looked a little bit more in to this: the device is definitely in the database

NOde 49- is the door windo sensor
NOde 48- is the 4 in 1 motion / temp/ humidity sensornode48.xml (11.1 KB)

i have attached the node file it createsnode49.xml (8.1 KB)

Maybe I missed it, but you don’t say what version of OH you are using? Normally the ? in the security state means you are running a version of the software that does not have security (eg 2.3).

thanks Chris- openHAB 2.3.0 Release Build

while i was browsing i came across this other post - should i continue discussion here or should i move that other post?

I would suggest to upgrade to a newer version before continuing any discussion :wink: . Your version does not support security, so if you want to use it, then it will not be possible unless you use 2.4M4 or newer.

Thanks Chris. I found this link on the forum- is org.openhab.binding.zwave-2.4.0-SNAPSHOT.jar at the link below still the latest version of the binding that does secure associations?

Also, for the process to upgrade the binding, do the following steps below seem accurate or am i missing any steps:

a) delete all the things using paper UI
b) delete the current binding from paper UI
c) add the latest version of zwave jar file in

d) restart openhab
e) install binding again using paper UI- i am assuming now it will use the latest version from the addons folder?

thanks again!

No, use this one:$org.openhab.binding.zwave/

There is a better one:

Don’t (!) perform this step. Dropping the jar into your addons folder is sufficient.

thanks sihui! I will give this a try

If you encounter a dependency problem after upgrading see this thread:

to clarify, i an running openhab 2.3 on raspberry pi as manual install (not openhabian image). So openhab is running as a service.

After deleted all the things, i put the zwave 2.4.0 jar file in the add-ons folder, and restarted by pi, i dont see it is showing the error pointed above regarding unresolved requirement. To fix, i am supposed to run
“feature:install openhab-transport-serial” from the openhab console?

when i go to /usr/share/openhab2
and sudo ./
i get root instance is already running. so i stopped the service using “/bin/systemctl stop openhab2.service”

then i ran sudo openhab-cli start

at the openhab console, i ran
feature:install openhab-transport-serial

thereafter all the things start showing up in my inbox (most of them still showing unknown devices)- i will let this run overnight and see how it goes.

thanks for all the guidance!