Zwave Binding DUW_054337

Tags: #<Tag:0x00007efecb4846a0>

@chris
I just changed from vera2 to OpenHab, and my
DUW_054337 Wall Dimmer are coming up as 05433 One Paddle Wall Dimmer Insert



image

I can dim the lights from OpenHab, but it does not seem like OpenHab receives any updates from the dimmer, when I manually dim with the paddle.

OpenHabian @ Rpi4
OpenHab 2.5.10-1

Chris is dealing with issues after having to restore the database site from backups. Just be aware his response may be delayed.

I now realize personally how much we depend on that site for binding support.

2 Likes

If you can confirm that in the log, try removing the association to the controller, save Thing, readd the association, and save again. Being battery powered, you should wake the device up a few times, waiting ~30s (device dependent) between wakeups.

1 Like

First of all, its not battery powered. The info in the binding are wrong.
I tried removing the Controller and re-add. (how long should the pending... last on non-battery devices?

My Z-stick just got re-connected (as to excluding/including-state), and the whole network seemed to got polled, and the Dimmer actually responded with the right state (30% to 0)
That seems to be the only time the dimmer actually reports its state

What info is wrong? Looking at the database I don’t see any mention that this is battery powered? Please can you advise where the error is?

You need to ensure that the associations are set correctly to allow the device to send reports.

1 Like

oh. Somehow I’ve manage to mix things up. I’m currently linked to Reitz-Group.de 05433 One Paddle Wall Dimmer Insert
And somehow I thought mine was the Z-Wave.Me and should be linked to Z-Wave.Me ZME_05433 Zwave.Me Dimmer Set Everlux

Anyway, that doesn’t make the issue go away. Somehow OH doesn’t get any updates from the dimmer, when I manually dim the lights with the paddle. (Only when OpenHab sends some kind of global polling(?))
I believe the associations is correct? (default was none)
image

Got the same problem with my Duewi ZW BJ ES 1000 [2001:0000]

If the associations are really set correctly (in the device), then the reports should be sent. If there’s nothing being received in the debug log, then either the association isn’t set correctly, the device doesn’t communicate reliably (possibly an RF or routing issue) or there’s some other issue with the device.

I’d suggest to double check the associations first as that’s the most probable reason.

Thanks again @chris!
Ive got a few of those dimmers, and they all got the same issue (worked fine a week ago in vera2)

I’m also looking at the associations as the most probable reason. Do you got any tips on how to make sure its set correctly?

Given I think these are very old device, then there’s unlikely to be any issues around using newer versions of the association class (ie the MCA class), so I don’t really think there’s any scope for misconfiguration.

As I suggested above, I would recommend getting the debug log to see if something is received or not. You can then try doing a full initialisation (there’s an option in the thing config) and see what happens in the log.

1 Like

I tried removing the Association Group 1 (just to re-add) but its still there…

Attached a .txt with DEBUG. Should the DEBUG last longer?

DEBUG_duwi_remove_ass.txt (29.1 KB)

(I’m actually struggling with another (brand new) dimmer from Namron, thats got three Associations Groups with controller, that I cant remove. (I’m opening another thread for that))

While there seems to be an issue with removing the association, the important thing here is it shows that the device has the association configured as this is read back and displayed in the log.

Thanks Chris. I’ll keep on troubleshooting. Those dimmers are indeed old.

Is there any chance they are not able of instant feedback? I did not notice this before now, but my old controller (vera2) was polling every 60seconds…

1 Like

No - it should be fine - this is what the associations should do. What I would suggest though is to get a debug log when you change the switch state to make sure that there really is nothing being sent by the device. It’s possible the configuration is wrong and the binding is just no processing the data if it’s sent.

It didn’t show up in the debug log. I’ll run a few more test later.