Zwave binding issue

when I start network inclusion openhab finds 3 new devices. 2 of them are already in use and working fine, 1 is power-off (fibaro universal sensor). I can delete it from the list, but they re-appear everytime I scan the zwave network. can I somehow fix this, I guess there is some confusion with the internal DB? I normally start zwave inclusion for new devices in PaperUI and let PaperUI add it as a thing. all other configs Item, sitemaps etc. are done via visual studio code.

Well, it sounds like the binding is correctly discovering the 3 devices - if one of them is powered off, it’s still a device.

I think you have 2 options -:

  • remove the device that is powered off - eg power it on and exclude it from the network, or use the delete node option.
  • use the inbox ignore button which will hide the device rather than deleting it from the inbox each time.

The most suitable option is up to you - if the device is not going to be used any more, then it would be best to remove it properly from the network.

hmmm, I tried to exclude the device via HABmin, but it never worked. using the ignore button is not a permanent solution, each time I did a rediscover network the devices that were previously ignored came up again.
I then used HABmin to fail the device manually, then I was able to "remove device from controller.

Glad to see it’s solved :slight_smile:

Just FYI, to exclude a device, the device would have to be alive for the time you are excluding it as you also have to push a button on the device itself… If the device can’t be powered on, this wouldn’t be an option.