ZWave Binding: No symlink for zwave controller serial port in OH 2.5

I recently updated from OH 2.4 to OH 2.5
I used to have a udev rule do create a symlink to my zstick serial port:

/dev/zstick -> /dev/ttyACM0

this worked perfectly since OH 2.4.
After upgrading I noticed that my zstick was not recognized anymore. The configuration option for the serial port is now a dropdown (I think it was a text field before, right)? In that drop down I cant select my symlink but only the “real” device files /dev/ttyACM0 (and /dev/tty2).
Selecting /dev/ttyACM0 makes the zstick work, but since device names change from time to time, I would prefer to be able to select my “symlink”-device-file again.

That doesn’t seem to be an issue with openhab. I also use a symlink via socat and ser2net. My disk station gets the stick from a Raspberry and is in the system under / dev / ttyZWave
Now I mount the device from / dev / ttyZWave to / dev / ttyACM0 in openHAB (Docker).

Have you checked your Java Args? Is there an entry for your Symlink Device?

1 Like

You’re right. That option was missing in my /etc/defaults/openhab2. I can see that this file was overwritten during the upgrade process. So the configuration was lost.
I re-added it and now it is working as before.
Thanks for the hint.

1 Like

Please click the square box on solution post to mark as solved.


1 Like