ZWave binding updates

Hi Andrew,

My issue was the USB based Z-wave controller/bridge continuously (like every minute) going off and on line. The issue is known and can happen when a binding fails to load. In my case, it was Expire. The reason Expire was malfunctioning was bad formatting of a related item (e.g. user error). It was resolved when I uninstalled the binding, but as soon as I found the bad item and fixed that, I tried reinstalling Expire again - and all is now fully operational again.

I have issues with slow and unresponsive Z-wave as well, but relate that to lousy mesh. ^^



Skickat från min iPhone

1 Like

@chris do I see correctly that builds 28 and 29 are broken?

2020-04-19 15:23:37.305 [ERROR] [.thing.xml.internal.ThingTypeXmlProvider] - Could not register ThingType: zwave:aeotec_zw141_03_000
java.lang.IllegalArgumentException: ID segment ' switch_dimmer' contains invalid characters. Each segment of the ID must match the pattern [A-Za-z0-9_-]*.

Yes, this has been fixed and will be updated tonight.

unfortunately it is not in 2.5.4 :pensive:

Ok thanks

General question so might be better in another thread? I have some socket devices that for various reasons get unplugged - obviously these won’t work in this state and they seem to sit to the side of my mesh In the network viewer but could this cause issues/delays etc and does anyone have any suggestions on the housekeeping of these devices if this IS an issue? I’m still seeing periods of delays across the day when other times everything is snappy and wondering if this might be contributing

today I made an update from build 2.5.3-1 to 2.5.4-1, same here:

2020-04-20 14:50:54.529 [ERROR] [ng.xml.internal.ThingTypeXmlProvider] - Could not register ThingType: zwave:aeotec_zw141_03_000
java.lang.IllegalArgumentException: ID segment ' switch_dimmer' contains invalid characters. Each segment of the ID must match the pattern [A-Za-z0-9_-]*.

@5iver corrected that entry in Chris’ ZWave device database, but that change has not yet appeared in a recent build of the binding. I get the same error logged, but it is harmless as I don’t have a ZW141.


It should be included in the latest snapshots from yesterday, but I haven’t checked myself.

I saw that commit when I updated my clone of the GitHub repo this morning, so I assume it will be included.

Hello guys. I am sorry, but that error with the whitespace was mine. Although, I did not release the changes I’ve made.

In spite of this I have a few questions:
a) The ZW141 (FW 3.0 and above) has two modes: mode 1 supports simple shutters. Mode 2 supports shutters with venetian blinds. When checking the engineering document, I cannot find the correct channel names - how can find the correct ones? The one in the DB are just my guesses and I think now the ZW141 seems broken in Openhab and reverts to the version before FW 3.0 (less configuration parameters available).
b) What does the “Endpoint 0 has no command class linked to the basic class.” message mean in the @chris’ DB?
c) How can I check my changes BEFORE they are merged into the Z-Wave binding?
d) How do I know what version is used in the snapshot? Is there a log message from Z-Wave indicating the age of the DB?

It means exactly what it says. The documentation says the following -:

1 Like

Does this mean the error does not mean anything as long as I don’t have one of these devices (which I don’t)?

Exactly, yes. The error is logged when the Zwave binding reads the device specification files during binding startup. Since you don’t have a ZW141 in your setup, it’s not a problem on your system.

Awesome - thanks a lot for the lightning fast response ! :slight_smile:

Hi, i have problems after apt update / upgrade from today (RPI 4) as it seems the serial port is gone after installation

2020-06-02 12:47:35 status installed bluez-firmware:all 1.2-4+rpt3
2020-06-02 12:47:35 status installed rpi.gpio-common:armhf 0.7.0-0.1~bpo10+1
2020-06-02 12:47:42 status installed raspberrypi-sys-mods:armhf 20200514
2020-06-02 12:47:59 status installed raspberrypi-kernel:armhf 1.20200601-1
2020-06-02 12:48:02 status installed raspberrypi-bootloader:armhf 1.20200601-1
2020-06-02 12:48:02 status installed libraspberrypi0:armhf 1.20200601-1
2020-06-02 12:48:02 status installed rpi-eeprom-images:all 7.1-1
2020-06-02 12:48:02 status installed python-rpi.gpio:armhf 0.7.0-0.1~bpo10+1
2020-06-02 12:48:03 status installed grafana:armhf 7.0.1
2020-06-02 12:48:04 status installed pi-bluetooth:all 0.1.13
2020-06-02 12:48:04 status installed libraspberrypi-doc:armhf 1.20200601-1
2020-06-02 12:48:04 status installed libraspberrypi-bin:armhf 1.20200601-1
2020-06-02 12:48:04 status installed libraspberrypi-dev:armhf 1.20200601-1
2020-06-02 12:48:06 status installed rpi-eeprom:all 7.1-1
2020-06-02 12:48:06 status installed man-db:armhf 2.8.5-2
2020-06-02 12:48:06 status installed systemd:armhf 241-7~deb10u4+rpi1

it finds the stick but no serial port /dev/ttyAMC0

[14:33:34] root@openhab:/var/cache/apt/archives# lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 0658:0200 Sigma Designs, Inc. Aeotec Z-Stick Gen5 (ZW090) - UZB
Bus 001 Device 003: ID 045b:0229 Hitachi, Ltd mSATA Adapter [renkforce Pi-102]
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

[14:40:04] root@openhab:/var/cache/apt/archives# ls -ltra /dev/ttyA*
crw-rw---- 1 root dialout 204, 64 Jun 2 14:18 /dev/ttyAMA0

[14:43:05] root@openhab:/var/cache/apt/archives# dmesg -T | grep tty
[Tue Jun 2 14:16:04 2020] Kernel command line: coherent_pool=1M 8250.nr_uarts=0 cma=64M cma=256M smsc95xx.macaddr=DC:A6:32:4F:E1:CE vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000 console=ttyS0,115200 console=tty1 root=PARTUUID=e7fb8469-02 rootfstype=ext4 elevator=deadline rootwait
[Tue Jun 2 14:16:04 2020] console [tty1] enabled
[Tue Jun 2 14:16:04 2020] fe201000.serial: ttyAMA0 at MMIO 0xfe201000 (irq = 34, base_baud = 0) is a PL011 rev2

any idea or rollback ?

What version of OH to what version? Details can be important. I think @wborn has been doing some recent research on serial.

Since you have a Pi 4 is the stick plugged in to a USB2 hub as recommended? That stick incorrectly says it supports USB3 but does not work on a USB3 port directly.

i’m running OH2.5.5-1, never used USB hub (the outside port (black was working till today)

Since i don’t have USB2 hub here i swapped disk and Stick to RPI3, working now !

1 Like

I believe it should work ok - I’ve not tested the latest version, but the only changes are around the serial port, so if the controller comes online, then I would expect that it will probably work.


Thanks, afraid it doesnt work! Question marks come up on the nodes in Habmin. Rolled back…