ZWave binding updates

Tags: #<Tag:0x00007f433d366dc0>

Thanks Chris, all working now. DB update has recognised the device and all is well! Thank you once again

Dear All,
I need some help with this, after mygrating from 2.3 to 2.4 and now 2.5.0. My VRCS2 switches with 001d:1102 id are unknown to the database. Please advice how to sort this issue out.

cheers,
HAB123

Hi

VRCS2 is in the DB but with a different Reference Type https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/418
as 001D:0000. I don’t know if it matters or not - but I would assume yes.

@chris ??

Regards
Stefan

Good assumption :slight_smile:

I’ve added 001D:1102.

Chris

Thanks Stefan and Chris!, thanks so much for your help and quick reply!.. it could sound very stupid but now what should I do?. Remove the the devices and add them again, remove the binding and add it again?. Forgive my lack of knowledge, Im new to OH :sweat_smile:!

Cheers,
T

Upgrade the binding once a build is available which includes the change, which could take a few days. This can help in getting it installled…

Hi Guys

I have an issue with 1 of my Aeotec nano Dimmer, firstly the manual switch would not update the openhab server even though it is set to & all of my other Nano Dimmers are working fine. I then have excluded it from the network, deleted the thing reset it to defaults and re included and now i’m getting the following:


Is there any way I can re add the device but under a different node number? it keeps re adding as the same node2

At a guess, the device may not have excluded from the network. When the binding starts, it asks the controller for the list of nodes on the network, and then tries to contact them. If the device didn’t exclude, then the controller will still think it’s on the network - if you reset it, then it won’t be, but the binding will continue to try to talk to it as the controller still thinks it’s there.

To confirm this, we’d need to see the log during startup when this information is exchanged.

To get out of it, you will need to remove the failed node - there is an option in the thing parameters to do this - you would need to add the thing back again of course (and it doesn’t always work unfortunately).

Hi Chris

I have atatched the log at start up

zwave.txt (352.8 KB)

This confirms the above theory - assuming node 2 is the old node, the controller still thinks it is included in the network, so the binding will continue to try and communicate with it.

No matter what I try I cannot get the device to remove from the controller. I have tried paper ui, habmin & zensys tools but the device wont mark as failed or remove.

I managed to use the Zensys tools to replace the device with the same device, re added to openhab and so far everything is working again.

@chris thanks as always for the fast response & putting me in the right direction!

Thanks Scott,

I checked the tutorial script but It is not clear for me if It should be done or not for zwave! I ran the script, I was ready to Install it but decided to be patient ahahahha… I think I can wait until the binding is updated!. @chris would it be to much to announce here whenever the updated binding is uploaded?, so I dont apt-get update / upgrade everyday?:sweat_smile:

Cheers,
T

Yes, it works for zwave… just don’t select Development (use Snapshot). If you’d rather not use a manual install, there is another option here, just replace the 2.4s with 2.5s. The change for your device is not yet in the binding.

Hi guys,
I have successfully added a new zwave device to the database MH-C221 and it was approved recently, but what is the next step? how to update my zwave binding on OPNEHAB2 in order to read the new device?
Thank you

Have you read the post just before yours? There’s also another option a little further up. The build system has had some changes recently, so it may take longer than normal for a new build to be available, so here is a third option.

After a device has been approved in the database it needs to be merged into the binding, so please watch the MCO Home folder:

After you see the merged device there it will take another couple of hours until the new zwave snapshot binding is available:

https://ci.openhab.org/job/openHAB2-Bundles/org.openhab.binding$org.openhab.binding.zwave/

Hi @chris , just updated from 2.4.0 M7 to 2.4.0 and been trying to get the binding to work, until i finally saw that the https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/787 doesn’t have a switch parameter anymore zwave:device:controller:node5:switch_dimmer, is this intentionally or?

Yes, this would be intentional. Since this is a dimmer, it doesn’t require a separate switch channel.

ah ok, i used that to turn on the light, have to change my rules for that then.