ZWave binding updates

zwave
Tags: #<Tag:0x00007f51def44610>

(J Wee) #482

Well that does not sound good as it was left like that all night. Node 5 is the repeater so probably does not mean much?

Is there a setting I have missed that causes my nodes not to wake? What should I do?


(Christoph Nagel) #483

Thank you, Chris! I appreciate your effort! :+1::blush:


(Christoph Nagel) #484

Hi @chris,

I wanted to give it another try concerning my problem (ZWave binding updates). So I did the following:

  1. put the ZWave binding into DEBUG mode
  2. deleted the openhab.log file
  3. restarted openhab by “sudo systemctl restart openhab2.service”, so the log file starts with the start of openhab
  4. at 11:46:… woke up node 21 (Danfoss LC thermostat) manually to get the actual temperature setpoint (22°C) displayed on my sitemap in the iPhone app
  5. at 11:46:30 I changed the temperature setpoint by iPhone to 25°C
  6. at 11:46:36 I woke up the thermostat again manually
  7. at 11:47:01 I woke it up manually again and finally temperature changed at the display of the thermostat to the desired 25°C
  8. I waited 5 minutes more until I stopped DEBUG mode

If you look at the log file directly without using the log viewer from your website you’ll see for about 24 seconds (from 11:46:37 until 11:47:01, which is the period of time between the two manual wakeups) the following entries:

2019-01-16 11:46:37.419 [DEBUG] [ng.zwave.internal.protocol.ZWaveNode] - NODE 21: WakeupTimerTask 3 Messages waiting, state DONE
2019-01-16 11:46:37.920 [DEBUG] [ng.zwave.internal.protocol.ZWaveNode] - NODE 21: WakeupTimerTask 3 Messages waiting, state DONE
2019-01-16 11:46:38.419 [DEBUG] [ng.zwave.internal.protocol.ZWaveNode] - NODE 21: WakeupTimerTask 3 Messages waiting, state DONE

and so on …

So, here you can download the current openhab.log file: https://www.dropbox.com/s/4bfx1wq0zv90r5k/openhab.log?dl=0

Thanks and regards
Christoph


Danfoss Living Connect LC-13 thermostat and ZWave Binding Update 2018
(Ricardo Costa) #485

Hello and good afternoon to all.

I am running openhab on a windows 10 machine in the stable 2.3.0 release. When I tried to update to 2.4.0 stable and follow all the procedures above with the Zwave Binding I did not manage to put my Fibaro FGR-222 Rollershutters like they where in 2.3.0. I followed the above steps and changed the recommended settings about the polling period and the chanels do not get updated acordingly. As my final test i removed the zwave controller AeonLabsZ5Stick thing cleared thje che and tmp folders and removes the zwave folder that contains all the *.xml files and added evrerything back again, but without success. I even tested putting all the modules in inclusion mode again, and there are some modules that report diferent parameter settings then they had back at 2.3.0. I tried seeting the parameters through PaperUI and or Habmin and there where errors in the log saying that it was Pending and in Habmin there was a notification on the side of the parameter when I hit save saying Pending also. I did not know what else to do so had to revert to 2.3.0 for the system to stay functional again. To revert back I had to start from scratch again with every configuration. For now I only have 9 devices but I would like to add more to the network and also do the upgrade. I tried this procedure two times with the but without success. I don’t know what to do anymore.

Thanks for your comments and for your good work.

Best regards.


(SiHui) #486

After upgrading to 2.4 you just need to delete your Things and readd them. That’s it.

Yes, possible. The database is updated regularly for improved/changed/better functions.


(Ricardo Costa) #487

Thanks for your fast reply. But I followed all the above steps, those included and I did not manage to have a setup working like it was in the previous version. Power reports where not beeing upated, Even the secenes detection when I pressed the buttons where not arriving… I made configurations with PaperUI, with Habmin, PaperUI always reporting Thing updated but in the log in the events.log I saw that it was pending. In Habmin a pending message also appeared. I have been at this two time for hours with no success. I must be doing something wrong, but the steps are easy and it should be really staight forward.

Thanks again.


(SiHui) #488

This is normal for battery operated devices: you need to wake those up manually (check your manual) until the changes got transferred to the device.


(Mark) #489

But the manual for the FGR-222 says its mains-powered, not battery powered.


(SiHui) #490

Damn, I need to read the whole post and not only part of it :grinning:
Anyway, I have six of those FGR222 and they are working great with the improved binding, there were no issues after updating from the development version :sunglasses:


(Mark) #491

Are all 9 of these FGR222’s, or do you have other devices, too? If the latter, are the other devices working correctly?

How did you define your items? If in an items file, is it possible that the channel UID changed (maybe you readded the serial controller and it now has a different UID).


(Ricardo Costa) #492

Thanks for your replies. All 9 devices are FGR222’s. Everything was defined in PaperUI/Habmin and the items in the items file. I created the Zwave serial controller with the same UID so that I did not have to touch the items. Some channels are updated, most of them not, and the pending status when changing parameters is a strange issue. Also I tried a calibration procedure and I noticed that the command had a high delay in reaching the controller and they are in the same room. Strange issues. Could it be from upgrading on Windows? This is already my second upgrade but this time the upgrade script did not work and I had to manually upgrade, and followed everything step by step. I don’ t understand these issues.
Which controller are you using? Mine is from AeonLabs. But sure it is not the controller because it works perfectly in 2.3.0


(SiHui) #493

What about the most important one, blinds_control?
Did you check via karaf if you have only one zwave binding active? (bundle:list | grep ZW*)
Did you clear cache and tmp folders and restart openHAB?


(Mar Li) #494

a little offtopic, but just wanted to give you an update.

I’m running openhab 2.4 with new stable zwave binding for 3 weeks. before, I ran openhab 2.2 and 2.3 with several unofficial development security zwave bindings (but some month ago that I updated an unofficial zwave binding). I always had the problem that my association groups and responses from devices to controller didnt worked correct/or just for one day and the next it was crappy again. nothing helped (reinstallation openhab, reinstalltion bindnig, reinstallation of all things, reinclude all things to controller, …)

now woth OH 2.4 everything is running stable for 3 weeks without any problems and it is important for me to give you this feedback because in the last month I was a bit evil to openhab and zwave binding and I was near to switch to some other HA tools.

thx guys for your hard work!


(Ricardo Costa) #495

That channel updates but not on all, and the network gets very slow…strange. For my rules the other channels like actual power (that’s how I detect that the rollershutter is moving) are important two and these do not update as usual, I have to force the refresh in Habmin or send a Refresh command and even so not always they are updated. I cleared the cache and temp folders multiple times and verified if there was only one binding installed through Karar.
I really love openHAB and I really want to do this upgrade but until now it was not possible…Maybe fresh install?
Thanks again for all your effort and support. openHAB has really has very good team.


(Mark) #496

Might be time for a debug log so that we can see what’s going on.


(Ricardo Costa) #497

Absolutely agreed. I just new a few days until I can start and set everything up again so that I can send the log.

Thank you for the support.


(Ricardo Costa) #498

Hello and good morning,

I did a fresh install of openHAB and installed only the Zwave Binding, added al the things (Controller and the 9 Fibaro FGR-222 Rollershutters) and enabled the log. Blinds controll channel is updated, the energy metering channels do not get updated during the rollershutter motion not even after the rollershutter stops.

Whent back to 2.3.0 and all is good again.

The log is too big to attach, here it is:

Thanks again for all your help.


(Chris Jackson) #499

The meter reports are being received. I do see some meter requests being received and processed - lots aren’t attributed to channels, but some are.

Maybe it’s related to linking of items to channels? When you change between 2.3 and 2.4, what are you doing exactly?


(Mark) #500

What about the group 3 association being removed here.

Even though it’s in the earlier config update here.
fgr-1


(Mark) #501

The manual says group 3 is for controller updates, so might that explain why he’s not getting updates?