ZWave binding updates

I was on OH 2.3 and I upgraded to Chris zWave binding 2.5 many months w/o any issues at all. You do need to follow his instructions for upgrading though.

When I did upgraded to OH 2.4 later; the zWave stuff worked w/o any changes.

Best, Jay

2 Likes

Hey all,
I upgraded from 2.3 to 2.5M1 two days ago. In 2.3 all my 33 node were working fine. After the upgrade most of the stuff started working flawlessly after following the best practice procedure.
I just have a few devices that are not recognized properly. Even after few hours as well as a nightly heal.
E.g. I have 2 identical Fibaro flood sensors. One is detected properly like this:

Z-Wave Node 032: FGFS101 Flood Sensor
FGFS101 Flood Sensor

And the other one looks like this:

Z-Wave Node 033
Unknown Device

I’m quite sure they are on the same firmware and have both worked on 2.3.

Same with a Fibaro FGD212 Dimmer 2 as well as two FGMS001 Motion Sensors. I have several nodes of the same hardware/firmware operating properly.

Any idea on how to reactivate them?
Thanks much for your help.
Seb

Wake up the battery devices.
Don’t forget to delete the Things and readd them if upgrading from 2.3.

Hi,

I have a new version of the config for a Fibaro Smart FDBS 222 Implant with 4 of the 6 optional temperature endpoints connected. I know there is a thread somewhere that explains how to submit and update database but I can’t find it. I am not very used to the forum yet.

I have registered and raised a ticket on the devices site. Very happy to help by adding or editing and not expecting anything fast as Fibaro would take months to add a template for a third party if ever.

Please could someone point me to the thread that explains how to add and test templates.

I also have one that while it had no extra temperature sensors attached was not recognised. Possibly a new firmware version?

network_c1372986__node_64.xml (69.4 KB)

network_c1372986__node_66.xml (47.7 KB)

cheers,

Robert

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-database-guide

The sensor was added recently, you will need a 2.5 zwave snapshot binding to have it recognized.

1 Like

Must be level of access. I can’t see the link. Will wait.

Many thanks.

This one?
https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-database-guide
No, you don’t need to login to view that page.

Sorry I am infamous for unclear posts. It is the button to upload an update that is not showing

“To upload an XML, select the Update Device option from the tools menu in the top right of the device summary page.”

I have no Update Device option. Probably wise until I understand more.

Correct, for that you need to login :grinning:
But you won’t be able to add an xml as it already is present in the database.
Just upgrade your zwave binding to the latest 2.5 snapshot

The one that is in the snapshot is missing 6 endpoints (4 of which I am using) so I will need to add the new endpoints and build.

Just testing the one that is in the snapshot but I think it will not work without endpoints 8 + or am I misunderstanding how the templates work?

[quote=“robmac, post:753, topic:51080”]

Yes, if endpoints are missing you will need to add them manually

I am having trouble with setting the lifeline to controller for this node. I have a couple of other nodes that behave like this. Do you think this is one of those remove and add stuations?

Thanks @sihui,
Indeed, I removed all things already. Since its also for a dimmer 2 which is mains connected, this is quite strange. Will give the manual waking another try with the flood & motion sensors.

Thanks!

I manually installed the 2.5M1 Z-Wave binding and things seems to work quite well.

The only issue that I have noticed is that one of my devices that was working previously isn’t recognized.

Z-Wave Node 111 (013C:0001:0004:1.13)

Unknown Device

It’s a Philio TechIn Wall Dual Relay (1 Way) Switch Module 2 x 1.5kW

The log says

[wave.discovery.ZWaveDiscoveryService] - NODE 111: Device discovery could not resolve to a thingType! 013C:0001:0004::1.13

Any ideas someone what I can do to resolve that? Thanks. Cheers!

It looks like a newer version was added to the database so I’ve added your IDs to this. It should be updated tonight.

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/858

Thank you very much @chris

I guess it will be working fine in future versions then. Do you think that there’s any way I can fix it keeping 2.5M1 Z-Wave binding without upgrading? (I can’t go higher due to that I’m still on OH 2.3 for several reasons)

You’d have to edit the JAR file to add the new XML - it’s doable, but not for the faint hearted.

I’m not sure why there should be a big difference between 2.5M1 and 2.5 SNAPSHOT though. If the M1 version works, I would have thought the SNAPSHOT would also work, but I could be wrong.

Thanks. I tried the snapshot version first but gave it up after a few hours of fiddeling with it. I got into trouble with serial port communication and there was a message in the logs about a missing command or somthing similar. As a result, the Z-Wave controller never came online. After installing 2.5M1 things started to work.

Hi,

I have installed the latest zwave binding snapshot running on a 2.5.0.M1

I am having issues with the setup of FGBS222 Smart Implant using the version of template in the snapshot.

The device is detected but the initial setup of associations is odd and I can not set to the lifeline. Is this an issue with the snapshot, the template or just my install.

I can not set the lifeline?

Please could somebody give me some hints of what to try or check?

Cheers,

Robert

The association should be set even if there is an issue with the display in the UI. The latest binding should (in theory!) make it impossible to remove lifeline associations, so if you think this is happening, please provide a debug log showing what’s happening and I’ll take a look.