ZWave-Binding with oh2, cannot change parameters of things

Hello Community,

i installed openhab2 2.0.0 with zwave-binding.
discovering zwave-devices as things, creating channels and items works so far for me.
But when i try to change configuration-parameters of a device (thing) this does not work.
I tried this in PaperUI and with Habadmin but without success.

In my log file a see a curios message and i believe it belongs to the error. I attached a screenshot of that message. maybee someone can help?


Others are having the same problem. There’s another thread about this issue here:

Hello Gatekeeper,

i looked over to the link you provided. Thanks so far. This link descripes exact the error i have using PaperUI.
BUT: In contrast configuring my devices (things) using Habadmin also doesn’t work. The log extract also only comes when trying to update with Habadmin. Using Papui send a log-enry also show in your linked topic.

Additionaly Habadmin tells me that the update was done. but in fact it did not!

1 Like

You want to change a configuration parameter on your zwave device, like association group?

From the image you presented (image of the log) it seems to show that the ZWave binding received the command and presumably sent the configuration. Why do you say it doesn’t work? Do you have a debug log showing what’s happening?

Hi @mcdroemmel

Is your device a battery device?
If so, did you wakedup the device several times?
At HABmin, do you see a Pending state at the configuration place? (refresh HABmin screen)

Hi @chris, @FRamos

@FRamos: you are right. The two devices are battery driven. Its a smoke-detector (popp) and a fibaro motion detector. I thougt that they are “awake” because the are sending messages (for example the fibaro motion detector sends motion reports).
@chris: I say its not working because the changes are not reflected when testing the change with the device (for example changing the time for clearing the motion alert on the fibaro it didnt change in reality. I can also see this in the karaf-log that the motion-detector clears the alarm still after the default-time). And if i do an additional change on another parameter the ConfigStatusInfo-Message grows for every change, the prior change-tries are still in the list.

but i will try to manually wakeup the devices. Maybee thats the problem.

kind regards


so now i woke up my fibaro device before saving changes in habadmin.
but again nothing seems to hapen.
Also the ConfigStatusInfo-Message and now additionally time-out messages.
i attached a new screenshot from karaf-log und habadmin.
any ideas?

Please provide a debug log - it’s difficult to know what’s happening without this.

Hi chris,

how can i create a debug log?


Hi Chris,

i toggled debug on in karaf-console for package org.openhab.binding.zwave.
I tried to configure Node 5.
The logfile is attached. Because no text-files allowed i converted to pdf. I hope its ok

kind regards and many thanks for your support
openhab_debug.pdf (165.7 KB)

Unfortunately the change to debug was after the errors had stopped… If you’re in the console, use list command to get the zwave binding, then stop and start the binding.

Please also supply the log as a text file - I load this into a log viewer to display and it won’t work with the pdf. You can rename the log to XML and it will be accepted.

Hi Chris,

next try, hopefully better. But a lot of data.

i stopped the bundle, switched log to debug for Zwave and started the bundle.
Then i waited until no messages are on the zwave-things in habadmin (like pinging device etc)
After this i woke up the fibaro and then i made the change in habadmin which was quitted by habadmin with “Successful”.
Because the logfile is so big, i had to zip it and then renamed as xml for uploading.

kind regards
MatHay (120.4 KB)

It looks like it’s working fine -:

This shows setting of parameter 6 and then reading it back. There are other examples in the log as well so it seems like its ok to me…

If you want to view the logs yourself you can do so here -:

@chris I have the same behavior with several AEON ZW100 and one AEON ZW074. All are operated with usb power. I have the same logs and everything seems to be fine. I can’t change the value of the humidity calibration for example.

Please provide a log so we can see what is happening. In this case, the data from the device is clearly showing that the value returned is the same as the value set. We need to have the full information to debug - the device, but also the parameter number and logs are always useful. Often issues like this are caused by the system sending an incorrect value due to database (or other) problems.

Did this get resolved? I have had a similar problem trying to update parameters with the PaperUI on the AEON HEM DSB09104. Unfortunately, I too much of a beginner to provide much data, except I get a brief pop-up that says “thing updated” and -Error 404 not found. And the log file looks like this:

2017-03-15 18:34:12.087 [INFO ] [] - Received HTTP PUT request for update config at 'things/zwave:device:38944924:node2/config' for the unknown thing 'zwave:device:38944924:node2'.

I don’t know if it is relevant, but data reported from the device seems to use a different name

2017-03-15 18:23:23.952 [ItemStateChangedEvent     ] - ZWaveNode2_ElectricMeterKWh changed from 87.348 to 87.839
2017-03-15 18:23:23.956 [GroupItemStateChangedEvent] - Readings changed from 608.632 to 608.755 through ZWaveNode2_ElectricMeterKWh
2017-03-15 18:23:23.990 [ItemStateChangedEvent     ] - ZWaveNode2DSB09HomeEnergyMeter_ElectricMeterWatts changed from 1173.59 to 791.34
2017-03-15 18:23:23.993 [GroupItemStateChangedEvent] - Readings changed from 608.755 to 513.192 through ZWaveNode2DSB09HomeEnergyMeter_ElectricMeterWatts
2017-03-15 18:23:24.189 [ItemStateChangedEvent     ] - ZWaveNode2_ElectricMeterWatts1 changed from 395.01 to 389.84
2017-03-15 18:23:24.193 [GroupItemStateChangedEvent] - Readings changed from 513.192 to 511.900 through ZWaveNode2_ElectricMeterWatts1
2017-03-15 18:23:24.334 [GroupItemStateChangedEvent] - Readings changed from 511.900 to 417.630 through ZWaveNode2_ElectricMeterWatts2
2017-03-15 18:23:24.337 [ItemStateChangedEvent     ] - ZWaveNode2_ElectricMeterWatts2 changed from 778.58 to 401.5

I’m trying to change the reporting frequency and the AEON support engineer says I need to change parameter 101 to 6927 and parameter 111 to 60

The only suggestion I can offer is to try HABmin - I’ve seen this sort of issue with PaperUI in the past and often it’s solved with HABmin.