ZWave broken since upgrade from CentOS to Ubuntu 16.04

Update 3-1-2017: I’ve managed to resolve this problem but I don’t know what exactly fixed it. The ‘Data was not placed on stack’ exceptions are gone. I’m running as root on Ubuntu 16.04 using the latest JDK8 (111)

Ok, so I’ve upgraded from CentOS to Ubuntu 16.04, as I like Ubuntu better and wanted to upgrade before upgrading OH1 to OH2. I’m using the same source files for OpenHAB, the same hardware (Aeon Z-Wave stick gen5) and the same Java VM (Oracle 8 JDK latest 111). Now I getting a lot of errors from my Z-Wave binding:

2016-12-30 22:06:28.753 [ERROR] [b.z.i.p.s.SendDataMessageClass:43 ]- NODE 8: Sent Data was not placed on stack due to error 0.

It also seems a lot more Z-Wave messages then normal are being processed. Besides, when I send messages onto the Z-Wave bus, the get enqueued, but never get processed.

What I’ve tried:

  • Switch to latest OpenJDK 8
  • Run openhab as root user
  • Play around with zwave properties in openhab.cfg
  • Switch zwave binding from latest 1.9.0 to 1.8.3
  • Switch the USB port for the Aeon ZWave gen5 device

Would it help to switch to OH2? Any other ideas before I decide to switch back to CentOS 7?