ZWave: COMMAND_CLASS_SWITCH_BINARY for endpoint 2 not found

I lately had a major issue with my OH installation that has run for months: all of a sudden all zwave devices (around 50) were lost in configuration. The only way to get them back after hours was to delete the zwave usb stick and readd it. What happened then was that the id of the device changed and with that all things’ ids completely changed (as they are based on the id). Hence, I had to read all devices as new. Most of the devices do work now but some don’t. It is not that the device is not communicating with the zwave controller but it is not accepting commands.

The Zwave Binding is on 2.5.0.M1

While the fibaro rollershutter devices all work fine I have an issue with all of the FGS223 Double Switch 2 devices.

As it was not working I also reinitialized it. Still it doesn’t accept my command.

The current reaction on sending a switch command is:

2019-11-03 08:22:23.209 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 40: Command received zwave:device:77371ce0:node40:switch_binary2 --> ON [OnOffType]
2019-11-03 08:22:23.210 [nt.ItemStatePredictedEvent] - F2_Office_Main_Light predicted to become ON
2019-11-03 08:22:23.218 [DEBUG] [converter.ZWaveBinarySwitchConverter] - NODE 40: Command class class COMMAND_CLASS_SWITCH_BINARY for endpoint 2 not found
2019-11-03 08:22:23.223 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 40: No messages returned from converter

Thanks in advance,

You could have avoided that. When adding a thing (your stick) you can name the device type id the same as it was before :sunglasses:


I have several of them and they do work as expected. Does the second switch not work at all or are you just seeing that debug message?

Thanks @sihui,

you never stop learning. Anyway, it was weird though that any of configs of the zwave was lost. Never mind that…

Yes, as you were asking, all switches do not work. Whatever I send them as a command does not have an effect. It is not only one of these; all behave the same way (I have 10+ of them). And as I said the rollershutters of Fibaro do NOT have the same problem. Just to mention: all of them worked well for a quite a long time.

I am currently hesitating of an exclusion/inclusing as I want understand the root cause and even then I am not sure if that helps. However, if you want me to try that with one of them, I won’t mind. I just try to track down the problem systematically.


Very strange.
I would first going down the easy way: upgrade your zwave binding to the latest, delete the things and readd them.
I am on Snapshot #1665 (basically Milestone 3) and the FGS223’s are working fine.

Wow that is old. Any reason you did not update to at least Milestone 4? The latest snapshots work too. I use Scott’s script to just update the binding. It adds any dependent bindings too.

Yes, no time :sunglasses:

1 Like

I feel stupid as I cannot find the please to find the latest milestone version. I’ve looked around all links here (and there: ZWave binding updates) and I even know I did that before but still I cannot find the right place. Can you provide the link to me?


Ok, but then only delete the switches or do have to delete/re-add ALL devices ?

How have you installed OpenHAB? using openHAbian? If you are running 2.4 you are running a stable release and need to change your system to look for a testing release. There are menu options in openHABian to do that for you. Otherwise the instructions are here. I think this is the command you need.

echo 'deb testing main' | sudo tee /etc/apt/sources.list.d/openhab2.list

Then run sudo apt-get update and finally sudo apt-get upgrade

1 Like

1 Like

I am already on OH 2.5 and 2.5.0.M1 for the zwave binding.


1 Like

2,5 will be released at the end of this year. If you mean you are on 2.4 then the changes I mentioned are needed. You likely need to manually delete the bindings from yer addon folder first though and install the zwave binding after upgrading,

Yep, thx @Bruce_Osborn, that’s what I am gonna do now: deleting the binding via UI (paper ui or habmin) and then manually add it to the add-ons folder.

Then deleting the switches, search via inbox, adding them and pray it works and does not make my world worse :wink:

1 Like

Praying didn’t help unfortunately as I get an unresolved dependency

org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.zwave [253]
Unresolved requirement: Import-Package: com.thoughtworks.xstream; version="[1.4.0,2.0.0)"

What is the best way to resolve that?

That is why I use Scott’s script. I believe the README has manual installation instructions.

Ok, thanks,

for those like me who will be struggling a bit with the script from Zigbee and Z-Wave manual install script, here are the “solution”.

  • Even though you can copy it to the samba shared folder, if you then ssh into the server, do not go to /srv/openhab2-addons/ but be sure that you go to /usr/share/openhab2/addons

  • There seem to be some minor bash incompatibilities that lead to missing string functions like “lower” and “title”. So instead of using what has been documented in the Readme, use the following instead

    bash ./ --ACTION zwave --ZWAVE_VERSION Development

@Bruce_Osborne I am on now
@sihui I will now go on with the research and keep you two posted.

A big thanks / hug so far for the support!

1 Like

I just use bash ./ and answer the menu questions. I have opened an issue because the script fails to uninstall the binding from 2.5M4.

No luck today even with the latest binding!

Same result:
2019-11-03 12:51:13.332 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 40: Command received zwave:device:77371ce0:node40:switch_binary2 --> ON [OnOffType]
2019-11-03 12:51:13.348 [DEBUG] [converter.ZWaveBinarySwitchConverter] - NODE 40: Command class class COMMAND_CLASS_SWITCH_BINARY for endpoint 2 not found
2019-11-03 12:51:13.360 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 40: No messages returned from converter

I then manually clicked the switch on the wall and filled the logs to @chris 's log viewer which outputs the following:

Looks to me like a security thing? What do you think?

Is too old from you perspective?
@Bruce_Osborne Should I try your approach to at least get to M3?