ZWave: COMMAND_CLASS_SWITCH_BINARY for endpoint 2 not found

No luck today even with the latest binding!

Same result:
2019-11-03 12:51:13.332 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 40: Command received zwave:device:77371ce0:node40:switch_binary2 --> ON [OnOffType]
2019-11-03 12:51:13.348 [DEBUG] [converter.ZWaveBinarySwitchConverter] - NODE 40: Command class class COMMAND_CLASS_SWITCH_BINARY for endpoint 2 not found
2019-11-03 12:51:13.360 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 40: No messages returned from converter

I then manually clicked the switch on the wall and filled the logs to @chris 's log viewer which outputs the following:

Looks to me like a security thing? What do you think?

Is too old from you perspective?
@Bruce_Osborne Should I try your approach to at least get to M3?

That binding version is almost a year old, why did you not upgrade to the latest?

Because you forced me :grinning: I missed my daily nap and upgraded to Snapshot #1738.
Deleted all things and re-added them: everything is working fine.

I have never included any devices securely so cannot comment on that.
With the latest binding from today the FGS223 are working fine, though.

Ahh, now I get it: you deleted the controller, correct?
You need to have the old network security key from your controller:


If you did not save that in a backup you are out of luck and need to reinclude all of your securely included devices.

1 Like

The version you told me has dependency issues which is why I
used the script that @Bruce_Osborne gave me and it installed that version. :frowning:

The script installs the latest version from today, so you did something wrong.

Where would that backup be?

I don’t know where you keep your backups :grinning:

1 Like

Unfortunately it has gotten worse now :cry:

I tried to install the development version.

I have only installed the snapshot binding.
I believe the development option is only used when working with Chris to troubleshoot an issue where he makes a binding outside the normal build system. Since there currently is no such version, the script times out.
If you do not show a zwave binding installed you may need to choose the Snapshot binding again.

How is that a year old? 2.5 did not exist a year ago and the version starts with 2019. Here is the version in installed yesterday, IIRC.
235 x Active x 80 x x openHAB Add-ons :: Bundles :: ZWave Binding

With the script and the menu driven way I got the (was

So, I should be good now at least at that point.

@sihui If I found the backup where would I find the secret in that backup? Any idea?
20190120 means 20th of January 2019. For me that is almost a year :grinning:

1 Like

In your JsonDB, …Thing.json file

  "configuration": {
    "properties": {
      "controller_softreset": false,
      "security_networkkey": "AB CD EF GH ...",
      "security_inclusionmode": 0,
      "controller_sisnode": 1,
      "controller_sync": false,
      "port": "/dev/ttyACM0",
      "controller_master": true,
      "inclusion_mode": 2,
      "controller_wakeupperiod": 3600,
      "heal_time": 2,
      "controller_exclude": false,
      "controller_inclusiontimeout": 30,
      "controller_hardreset": false

As the JsonDB is backed up automatically, you should find it in your userdata/jsondb/backup folder.

1 Like

Of course, sh… happens.

No, my backup only contains several files all of which have the current network key.

Now, on to excluding the fibaro switch 2 which unfortunately needs to be reset because even exclusion doesn’t work without a sound connection to the controller

  • pressed b button until yellow, then b again. When I reconnect the switch 2 it blinks red. To me that says it has been reset
  • Problem is it won’t include even being 1 meter to the controller usb stick.
  • Even worse - I do not get rid of the node (=40) in openhab!

This is for documentation purposes as it drove me crazy!
How do I get rid of the node40 which was the switch2-node in openhab?

  • The switch is disconnected
  • In habmin I went to the node 40 and clicked remove from controller - still there!
  • I deleted the node in openhab - it comes back!
  • I even went that far at some point that I deleted the files in /openhab2-userdata/zwave (one called network…node_40.xml and one node40.xml. It comes back.
  • Also I checked the jsondb-Things.json - it doesn’t contain the node40 anymore.

Finally after I put back the USB stick to the Raspi and rebootet. It was gone. Maybe after all that stuff, I had restarted OH - who knows. I only wished I knew which of what I did above made it go away…

And finally I was able to include my switch again. I like to note at this point that out of frustration I pressed the first switch of the switch2 device really(!) fast - probably 10 times (even though 3 times needed). Fibaro doesn’t tell how quickly it should be but I get the feeling it must be subsecond. If anyone knows exactly, please share.

And, yes, finally (after a whole sunday of work) the switch works again in openhab.

Thanks @sihui and @Bruce_Osborne for the sustaining support.

1 Like

Try marking it as failed first & then remove from controller. If that does not work, you may need some tools outside OpenHAB. To be sure, I would wait a minute or so after marking as failed.

Thanks, I will keep that in mind. I still have a handful of switches to go … Maybe over the next hours I can document what the best approach is.

If needed, I have used a Windows program Zensys Tools to either clear a node or reset the controller entirely to start building the network from scratch.

Yes, I discovered that as well (see above) and the weird thing was that it showed that there was no node40 on the stick.

If it is not on the stick, just delete the Thing. If it is rediscovered, it is on the controller.