Zwave controler is always offline


The first installation of the zwave binding can take some time until all the dependencies are installed. I usually look at the logs to verify. Occasionally I have restarted OH.

I wait for the binding to finish installation before trying to add a controller

Thanks for your answer

Instalation of binding it doesn’t take too much time, maybe 1-2 minutes, but I also wait for a while before adding the controlles.
I’ve tried with only one dependency and whiout dependencies, but I always get the same issue

I think the issue with the Pi was it thinks a stick is usb 3 when it is actually usb 2 only.

Next week I may be setting up OoenHAB again to test a Z-zwave usb stick from a vendor.

Hi Bruce
I think I know what is the problem, but not clear about hoe to fix it. Checking documentation from Z-wave usb sitck manual I can see hte following:

Linux should appear as a /dev/ttyACM0 (or other numbered such as /dev/ttyACM1 … ACMx ) device, if it does not, you may need to manually install the CDC-ACM module (should already be a part of the Linux kernel) or re-install Linux.your code goes here

So it seem that I need to use tty ACM0 instead of ttyAMA0. But I don’t have that option when I want to chage serial port configuration in Paper-UI:

image

Also, I’m not able to see this tty in/dev/ folder :

[21:40:02] openhabian@openhab:/dev$ ls -l /dev/ttyA*
crwxrwxrwx 1 root dialout 204, 64 Oct 11 15:31 /dev/ttyAMA0
[21:56:24] openhabian@openhab:/dev$ ls -l /dev/ | grep serial
lrwxrwxrwx 1 root root           5 Oct 11 15:31 serial0 -> ttyS0
lrwxrwxrwx 1 root root           7 Oct 11 15:31 serial1 -> ttyAMA0
[21:57:22] openhabian@openhab:/dev$

But is included in /etc/default/openhab2 file

[21:57:22] openhabian@openhab:/dev$ cat /etc/default/openhab2 | grep SerialPorts
##   EXTRA_JAVA_OPTS="-Dgnu.io.rxtx.SerialPorts=/dev/ttyAMA0"
##   EXTRA_JAVA_OPTS="-Dgnu.io.rxtx.SerialPorts=/dev/ttyUSB0:/dev/ttyS0:/dev/ttyS2:/dev/ttyACM0:/dev/ttyAMA0"
##   EXTRA_JAVA_OPTS="-Djna.library.path=/lib/arm-linux-gnueabihf/ -Duser.timezone=Europe/Berlin -Dgnu.io.rxtx.SerialPorts=/dev/ttyS0"
EXTRA_JAVA_OPTS="-Xms250m -Xmx350m -Dgnu.io.rxtx.SerialPorts=/dev/ttyUSB0:/dev/ttyS0:/dev/ttyS2:/dev/ttyACM0:/dev/ttyAMA0"

Do you know how can install port ttyACM0 in openhabian and get that option in Paper-UI?

Thanks in advance

what is the output of sudo dmesg | grep tty ? My controller is at /dev/ttyUSB0 in a RPI 3B+ running Raspbian Stretch.

image

Hi Bruce

this is the output:

[23:36:40] openhabian@openhab:/$ sudo dmesg | grep tty
[    0.000000] Kernel command line: coherent_pool=1M 8250.nr_uarts=1 cma=64M cma=256M  smsc95xx.macaddr=DC:A6:32:29:88:73 vc_mem.mem_base=0x3f000000 vc_mem.mem_size=0x3f600000  dwc_otg.lpm_enable=0 console=tty1 root=PARTUUID=be1d5779-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
[    0.000702] console [tty1] enabled
[    0.840102] fe201000.serial: ttyAMA0 at MMIO 0xfe201000 (irq = 34, base_baud = 0) is a PL011 rev2
[    0.843350] fe215040.serial: ttyS0 at MMIO 0x0 (irq = 36, base_baud = 62500000) is a 16550

Thanks in advance

Based on that I would try either of the 2 options in the PaperUI. Whichever works. The OS only sees those 2 serial devices.

I’ve tried both options, but smae issue is there.
I think that only optionthat I have is be able to get ttyACM0 defined.
It seems that is not in my sistem:

[21:40:02] openhabian@openhab:/dev$ ls -l /dev/ttyA*
crwxrwxrwx 1 root dialout 204, 64 Oct 11 15:31 /dev/ttyAMA0

Have you tried using a usb hub between the Pi & stick?
The Pi 4 does not properly meet USB standards. The issue was discovered after the product was released.
Try that & run the dmesg command again to see if another port appears.

Not yet. Tomorrow I’ll try to buy a usb hub . Do you recommend anyone?

Many people found a cheaper USB 2 hub worked better because sometimes the Pi misidentified a USB 2 stick as supporting USB 3.

Hi Bruce

Thank you very much! Finally I fixed the issue with the following USB hub:

It seems that is aknow issue for Aeotec Z-stick GEN 5, in coase of using Raspberry PI 4. And the workaround proposed by Aeotec is to use a powered USB 2.0 hub in between RPi4 and the Z-Stick Gen5 . Althought I connected a USB 3.0 hub

I found the following post:
https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=245031&sid=2c71284006137282752555f8942858cd

and

After connect the USB hub, I was able to select port ttyACM0, and after select it. Z-stick went to online

Thank you very much for your help on this issue

2 Likes

This HUB worked for me;