Zwave Coolcam Motion sensor not working

I have three zwave motion sensors made by Neo Coolcam. I used them successfully with my old Domoticz setup but can’t get the motion channel to work.

The Lux and Battery channels work fine but motion does nothing. I have enabled motion within the properties.

Here are my items definitions any ideas?

// Motion Sensors
Switch  Security_Motion_LR      "Living Room PIR [%s]"  <motion>        { channel="zwave:device:657f1a0f:node2:sensor_binary" } // Living room motion sensor
Switch  Security_Motion_H       "Hallway PIR"           <motion>        { channel="zwave:device:657f1a0f:node6:sensor_binary" } // Hallway motion sensor
Switch  Security_Motion_L       "Landing PIR"           <motion>        { channel="zwave:device:657f1a0f:node8:sensor_binary" } // Landing motion sensor

// LUX Sensors
Number  Environment_Lux_LR      "Living Room Lux [%s]"  <blinds>        { channel="zwave:device:657f1a0f:node2:sensor_luminance" }      // Living room LUX sensor
Number  Environment_Lux_H       "Hallway Lux [%s]"      <blinds>        { channel="zwave:device:657f1a0f:node6:sensor_luminance" }      // Hallway LUX sensor
Number  Environment_Lux_L       "Landing Lux [%s]"      <blinds>        { channel="zwave:device:657fla0f:node8:sensor_luminance" }      // Landing LUX sensor

What did you set the other configuration parameters to? There isone for lux that defaults to 100. Maybe the current lux level is over that?

The motion sensor on these Coolcam PIRs is definately not working with Open2 Zwave Binding.

The propeties for the motion sensor are;
Sensitivity = 8
ON/OFF duration =12 (also had set to 600)
Basic Set Level = 99
PIR set to enabled
Reset = 8

Below is what is being logged with debug on

2018-08-04 13:36:31.813 [vent.ItemStateChangedEvent] - Environment_Lux_LR changed from 236 to 98

==> /var/log/openhab2/openhab.log <==

2018-08-04 13:36:52.985 [DEBUG] [WaveSerialHandler$ZWaveReceiveThread] - Receive Message = 01 0C 00 04 04 02 06 31 05 03 0A 00 07 CD 

2018-08-04 13:36:53.022 [DEBUG] [ve.internal.protocol.ZWaveController] - Receive queue TAKE: Length=0

2018-08-04 13:36:53.030 [DEBUG] [wave.internal.protocol.SerialMessage] - Assembled message buffer = 01 0C 00 04 04 02 06 31 05 03 0A 00 07 CD 

2018-08-04 13:36:53.036 [DEBUG] [ve.internal.protocol.ZWaveController] - Process Message = 01 0C 00 04 04 02 06 31 05 03 0A 00 07 CD 

2018-08-04 13:36:53.042 [DEBUG] [ve.internal.protocol.ZWaveController] - Message: class=ApplicationCommandHandler[0x04], type=Request[0x00], priority=High, dest=255, callback=0, payload=04 02 06 31 05 03 0A 00 07 

2018-08-04 13:36:53.046 [DEBUG] [ssage.ApplicationCommandMessageClass] - NODE 2: Application Command Request (ALIVE:DETAILS)

2018-08-04 13:36:53.049 [DEBUG] [ssage.ApplicationCommandMessageClass] - NODE 2: Incoming command class SENSOR_MULTILEVEL

2018-08-04 13:36:53.052 [DEBUG] [ss.ZWaveMultiLevelSensorCommandClass] - NODE 2: Received COMMAND_CLASS_SENSOR_MULTILEVEL command V7

2018-08-04 13:36:53.055 [DEBUG] [ss.ZWaveMultiLevelSensorCommandClass] - NODE 2: Sensor Multi Level REPORT received

2018-08-04 13:36:53.058 [DEBUG] [ss.ZWaveMultiLevelSensorCommandClass] - NODE 2: Sensor Type = Luminance(3), Scale = 1

2018-08-04 13:36:53.061 [DEBUG] [ss.ZWaveMultiLevelSensorCommandClass] - NODE 2: Sensor Value = 7

2018-08-04 13:36:53.064 [DEBUG] [ve.internal.protocol.ZWaveController] - Notifying event listeners: ZWaveMultiLevelSensorValueEvent

2018-08-04 13:36:53.067 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 2: Got an event from Z-Wave network: ZWaveMultiLevelSensorValueEvent

2018-08-04 13:36:53.070 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 2: Got a value event from Z-Wave network, endpoint = 0, command class = SENSOR_MULTILEVEL, value = 7

2018-08-04 13:36:53.073 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 2: Updating channel state zwave:device:657f1a0f:node2:sensor_luminance to 7 [DecimalType]

2018-08-04 13:36:53.083 [DEBUG] [.serialmessage.ZWaveCommandProcessor] - Checking transaction complete: Sent Message: class=SendData[0x13], type=Request[0x00], priority=Immediate, dest=2, callback=67, payload=02 01 00 

==> /var/log/openhab2/events.log <==

2018-08-04 13:36:53.085 [vent.ItemStateChangedEvent] - Environment_Lux_LR changed from 98 to 7

==> /var/log/openhab2/openhab.log <==

2018-08-04 13:36:53.092 [DEBUG] [.serialmessage.ZWaveCommandProcessor] - Checking transaction complete: Recv Message: class=ApplicationCommandHandler[0x04], type=Request[0x00], priority=High, dest=255, callback=0, payload=04 02 06 31 05 03 0A 00 07 

2018-08-04 13:36:53.096 [DEBUG] [.serialmessage.ZWaveCommandProcessor] - Checking transaction complete: class=ApplicationCommandHandler, callback id=67, expected=SendData, cancelled=false      MISMATCH

==> /var/log/openhab2/events.log <==

2018-08-04 13:37:07.868 [vent.ItemStateChangedEvent] - Date changed from 2018-08-04T13:36:07.840+0100 to 2018-08-04T13:37:07.844+0100

Has this got something to do with ir being a binary sensor? But it need more config in the items file?

Are you sure this report is for the PIR? This is the luminance channel…

The items should not require any additional configuration. If you can provide a log of the sensor update, I’ll have a look at what’s going on…

Thanks Chris for taking the time to look.

The Motion and Lux are handled by the same device in this case Node2

I’ve emailed you the log - hope thats ok.

Unfortunately it has no motion events in it - just luminance.

There is another option of course - the device is broken?

I have three - all show same behavior - all previously working with previous set-up

I notice in the properties there is a enable PIR function - is it possible that is not working?

I’m pretty sure that this is a device issue - either it’s broken (unlikely given you have 3) or it’s misconfigured.

I don’t know the device at all - if there’s something like this that needs to be configured, then I would say it’s highly likely it’s not set. How are you setting this? Are you waking the device up after changing the configuration?

here is the url to the manual

The manual says that param 4 enables/disables the PIR 0 (disable) 255 (enable). The properties sheet within openhab2 for the device has a selector with enable/disable.

I do have enable selected

You didn’t answer this question -:

Basically, are you sure this configuration is set? If so, I don’t know what else to say - I don’t think this is a binding issue given the device is not sending any data and without data, the binding can’t do anything :wink: .

No - I’m not convinced it is being set. I have set it in paper ui the clicked the tick button. This brings up device updated. I then wake it up a few times.

So it should be set, but sometimes I go back into properties and param 4 is blank - neither set or unset.

Is there anyway to query the device about its config?

Sorry, but you still didn’t answer this question -:

One I set the config I press the button on the device three time and this causes the LED to blink 5 times.

Ok, thankyou…

I would then suggest to get a logfile of this to see what is happening.

I have sent another log. The PIR did trigger a rule when it was updating but hasn’t since.

This will be because during initialisation, the binding polls the data to get the current state. It shows the binding is decoding the data ok, but as we already know, the device is not sending anything.

I don’t see any configuration being sent in this log - or any configuration coming in from the UI. What device did you set the configuration on?

What I was expecting is that you update the configuration of the device, then wake it up, then send the log. This should capture the binding sending the configuration to the device. You could also try enabling and disabling this configuration, and waking it up between - again, the objective being to confirm in the log that configuration is being sent to the device.

Are you sure you know which node ID belongs to which device? :wink:

It looks like you are configuring node 2, but then waking up node 6 so there is no configuration being sent…

Why not try setting this configuration for all 3 of these devices, then wake them all up a few times?

The latest log looks good…

At the beginning of the log it is disabled (00 in the second to last byte) -:

Later in the log, the SET command is sent with FF as the parameter, and then this is confirmed with the GET command, which also returns FF, so we can be pretty sure this parameter is configured -:

So, this device looks like it should be enabled now, so the big question is if it is working?