Zwave device added, but no matching file in /var/lib/openhab2/zwave

Tags: #<Tag:0x00007f616dba6708>

Using a RPi3B+ running Master, I tried to add a new Zwave device. Shows up in the inbox as Node 54 with status Unknown device. Check ed Zwave database and it’s there so I figured maybe I needed to update something. Went looking in /var/lib/openhab2/zwave for the node54 file and it’s not there. What would cause that file to not get created. I checked permissions and they seem correct. I did delete it from the Aeon stick and Openhab and then tried to add it again, always with the same result.

I guess if it matters, it’s a Zooz ZSE18 motion sensor. I’ve waited a week to see if it would get all the data because it’s battery operated, but it never did.

This instance has been running for a year or so, though a few months back I had to start over after having to replace the SD card, that was fun

Ira

The file is not created if the device is not known. You should not worry about the file generation - the question is why the device is not discovered.

My guess is that as this is a battery device, you need to wake it up so that the binding can discover it properly.

1 Like

Seems you were right. This was the most troublesome device to add I’ve ever come across. I finally connected it to USB power and set it near to the RPi and then kept waking it up. Always before they’ve showed up unknown at first and then corrected after walking up a few times. This one didn’t seem to do that. Thanks for the help, sorry for the bother.

Ira

OK, it seems included correctly as all it’s information is there, but There is no file in /var/lib/openhab2/zwave that corresponds to the new device. I know it makes no sense, but I’m trying to figure out if it was recognized as a motion sensor or if it was recognized as both a motion sensor and a repeater. Am I looking in the wrong place?

Ira

So, It seems at least in my case that those files are no longer made, but the information shows up in the files in /var/lib/openhab2/jsondb. I’m guessing you should be careful with those files and consider them as view only unless you know better than me.
Ira

What files exactly? Do you mean the XML? These are definitely generated - if it’s not generated for you, then there is a problem with your system.

No - that is totally different.

Well, the entry for Node55 exists in the json thing file and looks proper, but there is no matching node_55 file in the zwave directory.

In PaperUI Node 55 shows up correctly and lets me connect items and do everything I expect but the sensor does not seem to work. I’m running the current Master updated yesterday and again right now. Is there any way I can help troubleshoot this?

Ira

Sure - but it is completely different information. The json db saves the thing information that you configure in the UI. The XML stores information about the device.

What do the debug logs show?

I see lots of these errors:

2020-06-30 22:21:35.285 [ERROR] [e.internal.WriterInterceptorExecutor] - MessageBodyWriter not found for media type=text/event-stream, type=class org.glassfish.jersey.med

2020-06-30 22:26:35.285 [ERROR] [e.internal.WriterInterceptorExecutor] - MessageBodyWriter not found for media type=text/event-stream, type=class org.glassfish.jersey.med

2020-06-30 22:31:35.285 [ERROR] [e.internal.WriterInterceptorExecutor] - MessageBodyWriter not found for media type=text/event-stream, type=class org.glassfish.jersey.med

I just enabled debug. Is there something I can do that will cause that file to get updated?
Or do I have to remove it and re adopt it?

Ira

That’s nothing to do with ZWave - it’s probably related to the web server.

As I said above, the file should be ignored - it’s irrelevant to you really. Try waking up the device so we can see what is happening - as I said, it is most likely that the device needs waking up to complete initialisation.

1 Like