Zwave device Evolve LOM-15 fails to complete intialisation

See a picture of the device here

The device was excluded and re-included with the Aeonlab Z-Stick Gen5 controller (the controller blinked as expected, indicating that the device was excluded / included properly)

After restarting openhab2 I’m getting a warning

grep -i zwave /var/log/openhab2/openhab.log
2017-08-08 21:14:51.684 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 4: Device discovery could not resolve to a thingType! 0113:5252:3530::5.21

Habmin shows that the device is not in the database.

The site
shows a list of Evolve devices but the LOM-15 is not listed there

The zwave file is attached here: node4.xml (4.7 KB)

Related components versions:

openhab> feature:list
openhab-binding-zwave                       | 2.1.0            | x        | Started     | addons-2.1.0            | Z-Wave Binding
openhab-ui-habmin                           | 2.1.0            | x        | Started     | addons-2.1.0            | HABmin

Is the device missing from the database?

seems so…
check: on how to add it

1 Like

I would like to add the Evolve LOM-15 wall socket to the database, can I be given access?
I tried leaving a message in the site but I’m getting a message: “Please enter security code displayed in the image!” but no image is displayed even if I press refresh


Sure - please let me know your user name and I’ll update your access.

@chris I’m using Avner for this forum. You can use this username.

I believe that you need to:

Did you register using the same username (Avner) on ?

Ps: by the way: @chris whenever you can, please update my access also to be able to add devices (my username on is: “Angelos”)


1 Like

@chris, the user name is Moshkovitz


Thanks @chris,
I added the device (copied pasted the node.xml file) in here
I’m seeing errors

Device definition contains errors
`thingid` contains invalid characters.

and warnings ?

Endpoint 0 has no command class linked to the basic class.
Device supports configuration, but no parameters are defined.

I tried changing the device definition from LOM-15 to LOM15 but I’m still getting the error. I’m not sure what else to do.

I will fix this.

I’ll look at this and can probably fix it - otherwise we can ignore it…

If the device has configuration parameters, then you will need to add them to the database for them to be used. The device will still work without this, but you won’t be able to change the configuration.

Thanks @chris for taking care of this.
Can you instruct what is the next steps?

  • Do I get a notification when the changes are applied into the new database?
  • Do I have to update the binding to get the new database updates?


You won’t get a notificaiton, but I think this should now be included in the latest snapshot.

@chris I switched the installation repository from Stable to Snapshot, installed the latest snapshot and the LOM-15 works well.
Is it possible to switch the installation repository back to Stable, and use it with the snapshot zwave binding?

Yes, this is possible. You would need to uninstall the binding, then download the snapshot JAR and manually add it to the addons folder. Then in the Karaf console, use the following command to install the serial driver -:

feature:install openhab-transport-serial

Ok, and for that matter, Is it possible to use the Stable installation repository, with the development zwave binding? (to check secure zwave connection). I want to make sure that the development version doesn’t have breaking changes. Also, what is the roadmap for integration of the zwave Development binding to a Stable/Beta releases (as I remember the plan was to integrate it into the stable release sometime in July/August).
Thanks again.

Yes - I don’t think there have been any breaking changes since 2.1 so this should be fine.

I have a couple of niggling bugs I’d like to resolve at the moment.