Zwave device not updating OH from toggle switch

I have a “PAN04 In Wall Dual Relay(1 Way) Switch Module 2x 1.5kW with power meter” device

Device is registered and online and I thought configured correctly however when using the physical toggle switch the device does not update openhab. If using the OH2 interface, I can turn on and off the device as designed

Anyone have any ideas? Do I have a setting wrong?

Male sure you have the association group (sometimes called “Lifeline”, “Controller Updates”, “Group 1”, …) set to your controller.

Hi @sihui this was what I originally thought might be the problem - originally nothing was set in here, but before posting I have:

I first tried completing just Relay 1 and relay 2 but then tcompleted all three with the same result.

Oddly I checked other zwave things - none the same brand most devices I have are Fibaro and they dont have anything in the association groups yet they all work fine.

[EDIT] OK jut checked the fibaro double switch with no association group and that too doesnt update the UI (I hardly ever use this one manually) - I will update this one and see what it shows - but this wont resolve the above anyway

ok so if I wait long enough the UI does update. Not sure why its not immediate

although it does show nas not frequently listening - thought this was a battery device thing?

It doesn’t matter about this - it’s permanently listening - not frequently listening (ie the listening flag is ticked).

OK - thanks @chris is there a way to “speed things up” via paramaters?

Associations should be used to configure the device to report its state - if this is configured correctly it should effectively instantaneous. Anything else will result in a delay.

You should also make sure that you’re using the snapshot binding to be sure it’s up to date. I would then suggest to remove the association and add it back again.

Thanks @chris all other devices are near instantaneous- will try your suggestion thanks for your input