ZWave: FGMS001 Motion Sensor acting

Hi all,

I’m having a weird time with this device. It stopped updating recently and so after a bit of mucking around with it, I excluded it and re-included it.

It worked fine for a bit this morning… but now I just back from shopping and the lights didn’t come on.

The relevant bit of the logfile is attached…

When I triggered it manually (via paper UI), it all worked. So I think there’s something strange going on.

One thing I did notice, when I trigger it manually I see:
2016-12-22 17:47:59.135 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 45: Command received zwave:device:157b8d41438:node45:sensor_binary --> ON 2016-12-22 17:47:59.136 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 29: Command received zwave:device:157b8d41438:node29:sensor_binary --> ON 2016-12-22 17:47:59.136 [WARN ] [ding.zwave.handler.ZWaveThingHandler] - NODE 29: Command for unknown channel zwave:device:157b8d41438:node29:sensor_binary wi th OnOffType

NODE 29 was the Thing’s ID before I did the exclude/re-include (with node 45 being the new ID obviously). Anyone have any idea where node29 is coming from? I don’t have an xml file for that node.

Hmm. Now it seems to be working again… I’d still like to work out what’s going on with Node 29 though.