Zwave healing not working


OH2 beta4 here, on rpi3 / raspbian jessy / zstick gen 5

I have installed last week my zwave devices : main powered, can relay messages, associated near the controler before installing to definitive place.

and for a week, they have remained in habmin network inspector as alone, not showing any neighbour. network healing is set (during the night). I tried advanced options on nodes (healing), and on controler “sync network” resulting in :

2016-10-10 20:41:19.196 [WARN ] [age.RequestNetworkUpdateMessageClass] - RequestNetworkUpdate not placed on stack.

I have (stopped) restarted the pi with no success.

So I have downloaded openzwave control panel, started it on the pi, and requested neighbour update for each node there … wich worked perfectly so my hardware is not at fault.

So my conclusion is : healing does not work (under beta4)

That’s correct - it is not currently enabled.

hummm. It used to work on a previous snapshot I was using (because I had 3 device that did have neighbours, all included in habmin).

maybe this is also explaining why I have to include zwave devices 2 times, as the first time they are always detected as “unknown device” (?)

anyways, thanks for confirming that (which might be written somewhere that I missed ?)

No - not in OH2, the heal algorithm has not been enabled.

Ummm - the heal doesn’t mean that you won’t have neighbours. Neighbour tables are updated at other times (eg on startup).

No - healing will not influence this in any way. All the heal code does is update neighbours and update some routing tables, but this is done when needed, not just at 2am each day.

Once I get the new transaction code sorted, then heal will be enabled.

ok, then it is the inclusion process that suffers from a regression I suppose.

I have one more device to include, I’ll plug it in, include it, and edit the post to report the logs of the process

I’m not sure what you mean by this?

There is no reason why you should need to include a device twice. Including it twice won’t help anything as it will be a new node each time.

Humm, trying to be clearer. When I first include the node, it does not appear correctly in the inbox, see next screencap. It only appears as “node 13” :

So I click on the “delete” (“supprimer”) button here in the inbox, click again on zwave network inclusion mode, and only then my device is correctly detected and displayed (in the inbox).

I checked in habmin and the node does NOT have any neighbours (not even the controler) => here you will find the logs with the first inclusion with the binding in debug, then the “second include”, then a node heal.

That’s correct.

When a device is first added to the inbox, when it is initially included, the only information we know is the node number. After some time, the binding will download more information, and this should get updated. If it doesn’t get updated before you add the device as a thing, then it will still be updated later once the initialisation is complete.

ok thanks. (but the node is added without any neigbour)