ZWave items do not update status. Or, sometimes, some of them do

  • Platform information:
    • Hardware: Raspberry pi 3 with RaZberry z-wave board
    • OS: Openhabian
    • Java Runtime Environment: which java platform is used and what version
    • openHAB version: 2.4.0
  • Issue of the topic: please be detailed explaining your issue
  • Please post configurations (if applicable):
    • Items configuration related to the issue
      about 13 z-wave items, mostly Fibaro dimmers.

So I have been struggling about 2 months now. Had a perfectly good working Z-Way installation on the same raspberry pi, but wanted more functionalitiy, better UI etc. Installed OpenHabian. Ended up having to disassemble all my walls to get to and reset all Z-wave devices, as they were detected by openhabian, but acting up.

But in any case, all z-wave items are now responding to commands. But they are not updating the status back consistently. Sometimes they are. Mostly not. I’ve tried

  • Deleting all items, resetting them physically (in the walls), then re-discovering and re-adding them. This was early on, I am not 100% sure it showed the same symptoms as now, but I believe so.
  • The ‘Association’ route. I suspect my z-wave items never had the ‘controller’ as the ‘lifeline’ association, because when I started looking into it, the UIs were all buggy (both habmin and paperui), I added it, it was gone again some time later. Then I read this was all a UI bug, and that 2.5.0 fixed it. I ended up crashing my whole openhabian installation after upgrading to 2.5.0.M1. Fixed it by reverting to 2.4.0, now I’m back to square one.
  • reinitializing items
  • Deleting all channels/items and re-creating them from the ‘watt1’ instead of ‘watt’ etc for FGD212 dimmers. Did not help.

Worst part is, it works perfectly for some longer or shorter periods of time, which often leads me to believe that my latest fix worked. But now starting to think that I might have had the same problem from day 1, and it’s just intermittent.

A concrete example of what I’m seeing right now:
I guess we can all agree that slider shows 0%, number says 18%.
I went down, it was on quite dimly, I turned it off with the wall switch. Screen now shows
Log shows
2019-02-24 21:07:56.142 [vent.ItemStateChangedEvent] - zwave_device_967676d1_node10_switch_dimmer1 changed from 18 to 0

Trying to see some patterns in this, at one point I believed it was only my Fibaro dimmers, as it is mostly them. I also have a Fibaro double switch, also with watt metering. That usually works. But not always.

They have also been working flawlessly for some longer periods of time.

Only thing I haven’t figured out completely, which I suspect could cause some fuss is a small door sensor from Telldus. I struggled pairing and resetting it after moving away from Z-Way software, and now for some reason Openhab says 2 of them are discovered in the inbox, + I already have 1 paired, so 3 in total. (I only have 1 of these in reality) Could this cause all the havoc with the whole z-wave system? If so, how do I remove these triple copies? If I delete them from inbox, they just come back the next day.

Did you find a solution. It seems that I have the same problem.