Zwave: migrating from OH1 to OH2, devices stay "unknown"

  • Platform information: RPi3 / openhabian / OH2.1
  • installed bindings: knx (1.10.0), zwave (2.1.0), hue (2.1.0), mysql (1.10.0)

I’m on the migration to OH2. Zwave is one of my problems.

  • AeonStick + range extender are fully discovered, online and seems to work
  • but: all the nodes (5x Sensative Strips) are discovered as “Unknown device”, e.g. Z-Wave Node 4 Unknown Device
  • In my “old” OH1.8.3 setup all devices were fully discovered and working properly
  • I took the stick from the old machine and plugged it into the new RPi3 (no reset)
  • items have been adjusted acc. to tutorial

Information from Paper UI:

zwave_class_basic	ROUTING_SLAVE
zwave_class_generic	SENSOR_NOTIFICATION
zwave_frequent	false
zwave_neighbours	1,8
zwave_nodeid	4
zwave_version	0.0
zwave_listening	false
zwave_routing	true
zwave_wakeup_time	2017-11-11T14:45:14Z
zwave_beaming	true
zwave_class_specific	NOTIFICATION_SENSOR

I already tried to manually wake up (up to 10x) the devices but the only thing that changes is the wake-up time.

Any further hints that I can do?

You will need to wake up the devices for them to be fully recognised - otherwise the binding won’t be able to download the data from the device. It might sort itself out in a day or two (these devices have a long wakeup interval from memory).

Hi Chris

I already tried to do to the manual wake up (2x, waited 10min and tried again 10x, waited 20min and tried again 3x with stick 30cm close to the device). All I got was an update in zwave_wakeup-time, device remains “unknown” :frowning:

Is there anything else that I can try?

Interesting observation:

OH1 is on windows machine. OH2 is on RPi3. I just took the Aeon Stick and plugged it into thr RPi - with the result as decribed above.

Today, I plugged back the Aeon Stick to my windows machine and no information was lost - all devices are working properly.

Question for non-techie-understanding: it seems that the controller can remember it’s devices. Is it possible that I can transfer the configuration 1:1 to my OH2 machine, even when it means that I would have to use the old zwave 1.10.0 binding? Does this work?