Zwave network issues

  • Platform information:
    • Hardware: raspberry pi 4 openhabian latest

Good Morning all,

I have some issues with my zwave devices.

I changed on the weekend from the zwave server to openhabian and the zwave plugin. I added my zwave devices new (2 in total right now). For this I put them next to my raspberrypi 4 with razberry board and the inclusion was fine. Then I relocate my devices to the original place just 10m away no communication was possible any more. How can I rearrange the network?

Go to HABmin, select your node, go to Advanced settings in tools, execute “Heal the device”


1 Like

This works and I have done but after a while it goes back to “communication error” state…and I can not switch it on or off (it’s a fibaro switch)

Distance issue?
If it works close to the controller but not 10m away it is a range problem.

That was not needed: the Z-Wave network configuration is stored in the Z-Wave controller. You could have just switched from to openHAB (or openZWave, …) without resetting and redefining your Z-Wave network.

Did you have this problem while using the stack?

Are the Z-Wave controller (Raspberry Pi) and the Fibaro switches located at the same place now?

Which switches are you using? I only know of the Z-Wave switch modules you have to mount behind a mechanical switch (e.g., the Fibaro Roller Shutter 3). The range of these switch modules is rather big, unless you have extensive metal shielding or the Z-Wave module is mounted too deeply in masonry (hence the Z-Wave radio signals have difficulty propagating). Also, there’s a small black wire attached to these Z-Wave switch modules. This wire is the actual Z-Wave antenna. It must not be damaged, cut or replaced with a different wire as then the antenna will no longer work (it’s been cut to size to match the wavelength of the Z-Wave network in use in your region).

Most (if not all) Fibaro Z-Wave products have a builit-in range checker. Please read the manual to see how to enable it, how to read the range status (typically through different colours of an indicator LED), and how to disable again the range test afterwards.

If you also changed controllers to the Razzberry, it may not have the same signal range as your original controller.
I know you did not mention switching controllers but some people here do that and mention it later; :frowning:

I know, you need to tell @milo :grinning:

@sihui ist there a good way how to backup the zwave network with a razberry board??

Yes, install z-way: