Zwave not working, I'm at my wit's end

After months of bashing my head against a wall trying to get z-wave working, and reading thousands of pages on it, I’m finally reaching out to try to get some help.

I’m running OpenHab2 on my Raspberry Pi 3 with a Razberry z-wave hat,

After playing with all the usual suspects (serial port stuff) I seem to have the Razberry hat talking to openHAB (could anyone have come up with a more difficult of convoluted set of steps needed to do that???)

What I can’t seem to do though is pair any devices to it. When I search to add devices through OpenHab2 it asks me to choose a binding, I choose z-wave, it then sits searching for about 30 seconds, during that time, the red light appears on the Razberry hat indicating inclusion mode, but it never sees any devices. I have tried it with a z-wave LED bulb, a z-wave motion sensor, and a z-wave plug in dimmer module, all of these devices can be included and excluded on a different z-wave hub, but none show up at all in any search on the OpenHab setup.

What am I missing here?


2017-11-10 23:41:57.538 [hingStatusInfoChangedEvent] - 'zwave:serial_zstick:4d725078' changed from OFFLINE (BRIDGE_OFFLINE): Controller is offline to ONLINE
2017-11-10 23:42:17.564 [BindingEvent              ] - org.openhab.binding.zwave.event.BindingEvent@1d6b7e0
2017-11-10 23:42:47.651 [BindingEvent              ] - org.openhab.binding.zwave.event.BindingEvent@185d488
2017-11-10 23:42:53.873 [BindingEvent              ] - org.openhab.binding.zwave.event.BindingEvent@2ba186
2017-11-10 23:43:23.952 [BindingEvent              ] - org.openhab.binding.zwave.event.BindingEvent@1929c4a
2017-11-10 23:46:20.803 [BindingEvent              ] - org.openhab.binding.zwave.event.BindingEvent@1ba7350
2017-11-10 23:46:50.872 [BindingEvent              ] - org.openhab.binding.zwave.event.BindingEvent@17d8ed7


2017-11-10 23:41:53.569 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Connecting to serial port '/dev/ttyAMA0'
2017-11-10 23:41:53.596 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Serial port is initialized
2017-11-10 23:41:53.598 [INFO ] [mmandclass.ZWaveSecurityCommandClass] - Update networkKey
2017-11-10 23:41:53.626 [INFO ] [ve.internal.protocol.ZWaveController] - Starting ZWave controller
2017-11-10 23:41:53.627 [INFO ] [ve.internal.protocol.ZWaveController] - ZWave timeout is set to 5000ms. Soft reset is false.
2017-11-10 23:41:56.765 [WARN ] [ve.internal.protocol.ZWaveController] - TODO: Implement processing of Request Message = -- (0x0A)
2017-11-10 23:41:57.102 [INFO ] [age.SerialApiGetInitDataMessageClass] - NODE 1: Node found
2017-11-10 23:41:57.104 [INFO ] [age.SerialApiGetInitDataMessageClass] - ZWave Controller using Controller API
2017-11-10 23:41:57.105 [INFO ] [age.SerialApiGetInitDataMessageClass] - ZWave Controller is Primary Controller
2017-11-10 23:41:57.106 [INFO ] [age.SerialApiGetInitDataMessageClass] - ------------Number of Nodes Found Registered to ZWave Controller------------
2017-11-10 23:41:57.108 [INFO ] [age.SerialApiGetInitDataMessageClass] - # Nodes = 1
2017-11-10 23:41:57.109 [INFO ] [age.SerialApiGetInitDataMessageClass] - ----------------------------------------------------------------------------

Are you putting the Zwave controller (hat) into inclusion mode when looking for your zwave devices. That’s the only way it can discover them. I’m not familiar with the hat so I’m unfamiliar with how to turn on inclusion on your device.

With my Z wave usb stick, I turn on inclusion mode and then flip my new z wave switch on and off. As soon as I do that the stick flashes that it is now aware of the device, then OH can discover it. It boils down to first your controller (hat) needs to discover the device, then OH can discover it from the controller.

Hope this helps.


If I remember well, when you use PaperUI discovery, the Z-Wave Controller (hat, stick, etc) is entering into inclusion mode (the binding takes care of that).

You need to make sure that your remote Z-Wave nodes are put into inclusion mode also (usually there is a button or something that you need to do on the device itself).

I am not sure if the device can be included in more than 1 controller, so if you have already added a device to another system, exclude it from there and try again with OH2.

According to the light on the hat, it is in fact in inclusion mode. All devices have been excluded from their previous network, been factory reset where applicable, and have been put in inclusion mode.
I’m trying to figure out if there’s any way to troubleshoot this further short of dropping more money on another zwave controller to see if this one happens to be defective.

I don’t know the ‘hat’, but inclusion mode is only enabled for 30 seconds, so if it’s staying on for longer than this, then I would suspect there’s something wrong - or maybe something else other than OH is controlling it.

The light only stays on for 30 seconds.

Thanks for the help guys, I finally figured it out though. Turns out that the hat I bought on Amazon Canada was not a North American version, but a European version (different frequencies)

Now to try to get a replacement, they never should have sold the European version on the Canadian site!

1 Like