ZWave OH2 - EUROtronic Stella Z

Hi @chris,

first of all it’s time again to thank you for the great work you’re doing for the community and OH2/ZWave! It is much appreciated.

During the last weeks I continuously watched your commits and updated my zwave binding to the latest versions. Currently I’m running “”.

Unfortunately I still can not initialize my Stella-Z devices (Nodes 31-33):

From the log I see that the node wake up has some effect and that there’s communication going on; but no node .xml is created.

Full log is available here:

Shall I create an issue for this?

with kind regards,

Hi @chris,

as the first log today showed that there is communication & thata wake up can be changed I set the interval to 60 s - after a few hours I checked the system again and all three devices were initialized. Something I could not achieve with manual wakeups (did more than 5 per device).

The logs of today are available here: zwave- (2).zip

with kind regards,

Hi Patrik,
I’ll take a look over this in the coming days. I have a StellaZ here that I’ve dusted off so if I can find some batteries I should be able to test it out during the week.


I also had problems with these thermostats.

No all of the 10 are working. I was sitting about many minutes beside any of these to wake them up continually. One worked after 1 minute, some needed more than 15 minutes. I simply didn’t want to wait for them to initialize so i did manually. :slight_smile:
They really are a bit annoying.

@skeal how did you initialise them manually? Whenever I press the button, all I get is a NIF but no wakeup, so the thing is still unknown.

I hat to have time. I also gut only useless nifs. Suddenly there came the first init frame. Sometimes after clicking 40 or more times

Hi @DavidR,

after update to the latest zwave snapshot binding I was able to set the wakeup interval via to 60s; then after the device did initialize I set the interval back to my normal value for direct valve control (3600) - maybe this works for you as well.

After you change the interval press the wakeup a few times … then give it a few hours.

with kind regards,

Hi @patrik_gfeller, thanks for the reply, and yes I have set the wakeup but of course it sits there pending. I’ve pressed the button maybe ten times and get ten NIFs which the binding accepts, but it’s obviously waiting for a wakeup notification. I’ve tried 3 quick presses, which works for other devices. I’ve tried holding the button for 5 seconds. Removing and replacing the batteries. Next to try is 40 times as Thomas suggests, seems a bit random, but unless Chris works his usual magic soon, this is going in the bin!


what version of the binding do you use? I use; you may use “>bundle:list” in the console to check this.

Unfortunately there’s nothing else I can offer to help.

with kind regards,

Please make sure you are using the latest binding - ie one from the past few days.

Thanks Chris, Patrik, the new binding did the trick. The one I was using was 5 days old.

One issue I had, after setting the wakeup to 60 seconds (and the device accepted it), was that the binding set the wakeup time to 0. When I looked in HABmin Wakeup Configuration it said 0. I was able to reset it to 60 again, after a few button pushes on the device.

I do not use text files for Items, so I’ve been setting them up using a HABmin and PaperUI.
When I switch back to HABmin sometimes I have to refresh the browser (I’m using Chrome on Windows). The XML file says 60, so I do not know where the 0 came from.
Here’s a log. The set to 60 was at 10:06:54.463
and the set to 0 was at 10:14:37.364

Oh! I’ve just found out I cannot attach files.
I’ll post this for now and go read the rules!

Hi all,

… and the Stella Z story continues :slight_smile:. As I use the valves in direct control mode I need to set them up the following way:


I tried the “Binary Sensor” channel for basic & “Thermostat Mode” for setting the mode.According to the log I can see the thermostat mode set; but can not find the basic set. Do I do something wrong? How can I set the valve to direct control mode?

As workaround I tried to set the basic value to 0xFE manually with a zWave service tool - hope that will do the trick for the moment.

kind regards,

I’ll add Manual mode to the database.

1 Like

Hi Chris,

thank you for the database update; not sure if I read the changes you made correctly - but to set the valve to manual control also access to the BASIC command class would be required via channel. Is this already possible with the changes made in ?

productattachments-files-e-u-eur_stellaz.pdf (445.4 KB)

with kind regards,

Why? It’s not stated like this in the manual - at least not how I read it, and it would be very non-compliant way to do it if it did require this.

BASIC command class nearly always maps to another class - in this case the mode class. So, you can EITHER set the mode with the basci class using the mapping in the manual, OR using the mode class - not both.