Zwave OH3 Config Parameters

on the current stable most config parameters that should accept a value from e.g. 0-100 are only showing the possibility “disable” but wont let me just type in a number as it was the case in OH 2.x

Is this a bug or does the DB need to be edited for those devices?

Since you have given us no device information we can give no advice.

1 Like

well actually this is the case for many devices I have (many)
So I thought it might be a know general issue
The above is a PST02A as shown on the Thing Type on the screenshot

however this applies for many of my devices where any config parameter that should allow a value to be entered (at least in 2.x this was the case) I only have the possibility now to select from given choices …

edit: more examples

Please check the database for these parameter to see if Limit To Options is set to True. Probably it is, and if it is, and it shouldn’t be, then please update it.

1 Like

I have some PST02A device and my config looks different / fine (OH 3.1.0 build 2248):


@shorty707 I do not inspect graphics for such basic information.
IMO if it is not important enough to you to plainly type it out, it is not important enough for me to spend my time trying to resolve.

It is currently not set to True on those options but the entry was updated earlier this month. It appears the changes were not made then though.

EDIT Parameter 7 is split out into several parts. I am not experienced with working with that on the new site. Some pieces appear to be restricted to options but some options look incorrect due to copy/paste and not updating.

@chris Please review this parameter when you get a chance.

I am on 3.0.1 and see it for so many devices.
Thats why I thought it might (have been) a known bug. When you say it is not the case in 3.1.0 it seems so. I actually wanted to wait for stable 3.1.0 before I upgrade.

@shorty as I said above, please check the database. There was an issue with the database where some information was incorrectly set - you may have some such devices, so please check these yourself.

haven’t been logged in after it was moved from cd-jackson.
I am not allowed to see or edit that. username same like here.
if you would give me edit capabilities I review all affected devices.

I’ve updated your access…


1 Like


ok I checked a couple
they actually seem very good maintained.

e.g. Parameter is neatly chopped into the individual options … an in there correctly limited to the options

for me the param 5 looks like below.
I already tried to reinitialized the device.
(edit: I just seen in the log it is not executing the reinitalize … but I get this in the log:

00:24:23.802 [ERROR] [org.apache.cxf.jaxrs.utils.JAXRSUtils] - No message body writer has been found for class java.util.Collections$UnmodifiableMap, ContentType: */*

when was that issue with the database? maybe with 3.0.1 I have a version before the issue was fixed?


There was a database export issue that was resolved after 3,0.1 was released.

About 2 months before 3.0.1 was released, the default repo on GitHub was renamed from “master” to “main” and the export still tried to update the non-existent “master” repo.That is why I recommend anyone using 3.0.1 use a snapshot version of the binding.

well ok … I manually switched to 3.1.0 snapshot for zwave
now the config parameters are correct again :blush:

unfortunately all my Din Dimmers are unknown now … I have 16 of those and 2 different versions.

01:03:44.354 [WARN ] [zwave.discovery.ZWaveDiscoveryService] - NODE 84: Device discovery could not resolve to a thingType! 0159:0001:0052::3.1
01:03:44.359 [WARN ] [zwave.discovery.ZWaveDiscoveryService] - NODE 54: Device discovery could not resolve to a thingType! 0159:0001:0052::1.1

which should be here:

I see in the DB they were very freshly re-approved just 2 days ago

Somebody modified that about a month ago and did not ask for review.That can stop it from being exported. It appeared to be no major changes so I approved it to get it back into the database export.
We try to give somebody time to finish an edit before forcing an approval.

Those changes should be in tomorrow’s snapshot binding.

Thanks for the update. Let me ask a question to you and @chris

Despite changes that were not approved yet … shouldn’t the device at least in the “last approved” definition be exported? Otherwise there is always something missing for someone?

I went on github and see that in the last commit the DIN Dimmer from above was added again.
At the same time I also see now another device I have was removed … probably because something was edited in the DB but not approved yet? At least the formerly approved version would help that the device stays known at all.

I found some minor issues in the DB where e.g. the param should a allow a 0 to disable something but it is not configured that way. To help cleaning this up I add an “Option” disable as optional pssobility.
The Device gets flagged “Modified”… however when I go back to the parameter I changed my edited/added Option isn’t there. Is that per design before it is approved that my changes are not visible anymore to me?

A second question while cleaning up some devices. A lot of those Windows Sensor are from the same OEM and actually have identical Parameters.

For that PST02A they are really good maintained and the complex parameters broken down into small sub parameters. I have I few more variant of it that share the same config but are maintained not as well. I could only copy the “good maintained” version to another one when the parameters are all blank - right? Do you as admin have more possibilities. If I bring a master device to perfect state could you copy the parameters to other devices I tell you? If there are minor differences I would change them afterwards.

I believe that was the intent but, for some reason, there was no old configuration stored in the database for that item.

For OpenSmartHouse Z-Wave Device Database
this is the same now. In the latest code on github the device was removed and the “last approved” version is not there anymore.

The script exporting the database is separate from the GitHub repo. There is a database field for the previous version but it was not always populated, apparently.

while doing some clean ups in the DB I stumble over some topics which are not obvious to me.

→ Why are Option Values not shown on the UI
In the example the OH admin page lets me enter a digit for the sensitivity.

The database at opensmarthouse actually has two ways configured.
The Option Values are not mandatory so it is correct that I can enter the value directly.
But how about the “optional” Options value configured at the bottom?
Shouldn’t there be 2 possibilties on the UI … enter the sensitivity as number but also show the option box?