[zwave] openHAB 2.5.0 Build #1723 exception during startup

Tags: #<Tag:0x00007f4348e153d8>

Me too: posted my symptoms in this post (before reading this thread - lesson learnt :wink:):

@Bruce_Osborne, if you are running 2.5M3, could you try running the script to get the latest snapshot version of the binding? This would further confirm this is a binding issue and not something in core.

I have a test build with a new controller & 1 device iun a VM rhat I set up last night. Is that sufficient or do I need more devices?

You shouldn’t need any devices. I get the exception with just the binding installed and no devices (including no controller thing).

2 Likes

I went ahead and created the issue.

I got the 2 minute uninstall error.
I will uninstall te binding manually now.

Hold up

Too late. The files seemed to get copied but the script timed out. Restarting OH.

The cause is known, Chris did a db update, and the current build has the fix and is ready for download. I’ve tested and everything ran without exceptions. I’ve also pushed a fix for the install script, so it should be working now :wink:!

I need to download a new install script?
It would be helpful for those of us with short memories to link to the location we are supposed to install the script to. It took me some digging.
I did not realize your script worked with M3.

UPDATE:
Downloaded the script, selected snapshot & the binding appears to be working.

The script checks for updates when you run it and will prompt you if you’d like to update when the version of your script is out of date.

1 Like

So, the fix made it into the latest snapshot?
GitHub says it was updated 2 hours ago & the snapshot binding was built 2 hr 6 minutes ago.

Yes. The fix…

2 Likes

Thanks @chris that’s fixed my issues. Appreciate the speedy fix.

Actually I don’t think it will appear in the actual OH snapshot (i.e. for those of us who install through PaperUI et al) until tomorrow, right? The current SNAPSHOT is still 1725 as far as I can tell, unless the snapshot build happened in the last hour or so.

Correct… this is currently only available in the binding snapshot. You could use the script or run…

bundle:update org.openhab.binding.zwave https://openhab.jfrog.io/openhab/online-repo-snapshot/2.5/org/openhab/addons/bundles/org.openhab.binding.zwave/2.5.0-SNAPSHOT/org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar

This latter method is how the script will work in the future. It’s nice, since Karaf will handle the dependencies for you! Possibly, I’ll extend the script so that you could pull down the snapshot version of any binding.

I thought the binding snapshot was compiled as part of the build compilation.

The binding snapshots are built through openhab2-Bundles. There are lots of builds… https://ci.openhab.org/. It looks like an openhab2-Distribution build has been started and completed, so this will also now be in the OH snapshot. The openhab2-Core build failed (again!), so you will not see any of those changes yet in the OH snapshot.

I can confirm that running the bundle:update works like a charm. No more exception when restarting OH and no more warnings.

2 Likes

I’m playing with a script that will update any binding requested to a snapshot version. I think this should be built into the REST API, so that the version used for a binding (stable, milestone, snapshot) can be specified by the user.

3 Likes