Zwave permundo item persistence on everyChange

i have a problem storing data from a Zwave switch (permundo PSC132ZW) to influxdb on everyChange.
this is my .items

Number permundo_watt { channel="zwave:device:6da2696b:node3:meter_watts" }

and here my .persist

Strategies {
   everyMinute	: "0 * * * * ?"
   every5Minutes : "0 */5 * * * ?"
   everyHour    : "0 0 * * * ?"
   everyDay     : "0 0 0 * * ?"
   default = everyChange
Items {
   permundo_watt : strategy = everyChange, everyMinute, restoreOnStartup

it only stores the “everyMinute” strategy.

Other zwave components work well (Devolo, Fibaro). any ideas? thank you.

I believe this should be every5Minutes : "0 0/5 * * * ?" (look at example 1). Maybe this is preventing the rest of the file from loading? Are there any validation errors in the log during a startup or save of this file?

i changed the “5minute” entry. no effort at all.

using other zwave components working fine.

i can also see the “live-changes” of the permundo item in paper ui.
there is no error in the log.

How do you know that the values aren’t being persisted (are you actually looking into the db)? You could try debugging the persistence binding that you are using. You would probably use log:set DEBUG org.openhab.persistence.influxdb (I use JDBC). Running list -s |grep org.openhab.persistence in Karaf should provide the name of the bundle. It woul dbe interesting to see what it logs when values are changed.

Any chance you originally set the item up as a type other than Number? My items are in files, and sometimes when I first setup an item, I’ll get the type wrong and need to change it. But when I do this, I also need to go into the db (I use MariaDB) and change it there too.

Sometimes restarting OH after changing persistence helps.

1 Like

that was it.
just a simple restart. thank you

So it was the change to the persist file that fixed this? Or had you not restarted since setting it all up?

the restart solved the problem.
before restarting, the persistence only stored “everyMinute” not “everyChange”
after restarting the persistence stores everyChange AND everyMinute.
working fine now

I get that. :smile:

I was asking if the restart resolved this because you hadn’t restarted after initially changing the file, or because of correcting the error in your strategies?

after changing the file (adding the item to the .persist) :smile:
the strategy wasn’t the problem

1 Like