Zwave secure inclusion fails (ID LOCK 150, Error = Reason=SET_KEY)

have been struggeling with getting my ID Lock 150 securely included into my zwave network.

I have tried to include, exclude, using zensys tool to exclude, re-routed the entire home to get the Raspberry physically close enough to the lock, resetted the lock, but it still won’t include it. I have read a lot of threads and been trying to re-include it twice which was suggested somewhere, but nope.

The device is recognized correctly even when failed to include, but the security is not there.

When trying to include the lock from Zensys it works, and it also worked when I was running Domoticz, so the lock and the Aeon Z-Stick works.

When I looked into the logs I can see the following:
2019-10-28 21:05:18.351 [INFO ] [mmandclass.ZWaveSecurityCommandClass] - NODE 21: Using Scheme0 Network Key for Key Exchange since we are in inclusion mode.
2019-10-28 21:05:38.651 [INFO ] [alization.ZWaveNodeInitStageAdvancer] - NODE 21: SECURITY_INC State=FAILED, Reason=SET_KEY

Have I missed to set or change the security key in the configuration?
When looking at the Controller there is a 16 hex long key defined.

OpenHab 2.5M5, ZWave Binding: binding-zwave - 2.5.0.M3

How are you including the device? Are you excluding/resetting the lock, and then doing the inclusion via PaperUI or HABmin, or are you doing something else?

I have tried to include it via PaperUI (not HABmin)

Did some further searching and I saw that someone have had similar problems and when they changed they Network key and it worked for them. So will try to do that later tonight…

Is the process to change the key to just enter a new value in the Controller thing and hit save? or do I have to change it somewhere else?

Assuming the key has been set (which should be the case as it defaults to a random key if not set) then changing it probably won’t help. The device must be reset before joining it though.

However, yes, you only need to change it in the controller thing in OH if you want to change the key.

So yesterday I changed the Network key and tried to include it again, and it worked on the first attempt!

(Actually first I thought it failed because the ID Lock signaled red when included, but then after a few seconds something happend in OpenHAB and the inclusion was finalized!)

So it seems the default key which is generated has som problem since booth me and others has solved the secure inclusion by changing the key.


+1 on changing network security key to get included again.

+1 same here