Zwave serial port - Cant create controller


Last week i installed OpenHab2 for Windows and Linux. My windows-maschine as zwave controller was able to communicate with my fibaro wall plug. Everything worked fine.

At the moment im trying to install a z-wave controller on my Synology DS212j. I bought a UZB-Stick and installed OpenHab2 (OpenHAB- , Habmin, the z-wave binding (binding-zwave - 2.0.0.SNAPSHOT) and i installed Java 8.0.111.

I activated logging for zwave and but the whole system (incl. karaf, java and webservices) crashed during the creation of the first zwave controller. However … OpenHab2 crashes when i configure the port for the z-wave controller.

No crash without port configuration:

22:04:12.855 [INFO ] [smarthome.event.ExtensionEvent      ] - Extension 'binding-zwave' has been installed.
22:08:30.461 [INFO ] [smarthome.event.ThingAddedEvent     ] - Thing 'zwave:serial_zstick:1597fe92811' has been added.
22:08:31.716 [INFO ] [me.event.ThingStatusInfoChangedEvent] - 'zwave:serial_zstick:1597fe92811' changed from UNINITIALIZED to INITIALIZING
22:08:31.755 [DEBUG] [ing.zwave.handler.ZWaveSerialHandler] - Initializing ZWave serial controller.
22:08:31.818 [ERROR] [ing.zwave.handler.ZWaveSerialHandler] - ZWave port is not set.
22:09:37.447 [INFO ] [smarthome.event.ThingUpdatedEvent   ] - Thing 'zwave:serial_zstick:1597fe92811' has been updated.

The last lines of openhab.log:

2017-01-08 23:03:16.177 [DEBUG] [zwave.handler.ZWaveControllerHandler] - Controller Configuration update received
2017-01-08 23:03:17.301 [DEBUG] [zwave.handler.ZWaveControllerHandler] - Controller Configuration update port to ttyACM0
2017-01-08 23:03:17.491 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Stopped ZWave serial handler
2017-01-08 23:03:17.495 [DEBUG] [ing.zwave.handler.ZWaveSerialHandler] - Initializing ZWave serial controller.
2017-01-08 23:03:17.498 [DEBUG] [zwave.handler.ZWaveControllerHandler] - Initializing ZWave Controller.
2017-01-08 23:03:18.015 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Connecting to serial port 'ttyACM0'

Do i need to compile any ftfi-driver?! The autodetection for the zwave stick worked fine … imo. How can i install the zwave controller on my box?

By default synology system does not include drivers for ftdi chips. Other serial things might not work as well. Please check with installed.

Hey Lukasz!

Today i installed the HO2 last build (

And I installed the Jadahal UsbSerialDrivers DSM 6.0.

[  151.460000] usbserial: USB Serial Driver core
[  151.850000] USB Serial support registered for FTDI USB Serial Device
[  151.860000] usbcore: registered new interface driver ftdi_sio
[  151.860000] ftdi_sio: v1.5.0:USB FTDI Serial Converters Driver
[  151.860000] usbcore: registered new interface driver ftdi_sio
[  152.540000] usbcore: registered new interface driver cp210x
[  152.710000] usbcore: registered new interface driver pl2303
[  152.960000] usbcore: registered new interface driver ch341

Java Error:

# A fatal error has been detected by the Java Runtime Environment:
#  SIGILL (0x4) at pc=0x4a6eac1c, pid=25098, tid=0x507df470
# JRE version: Java(TM) SE Embedded Runtime Environment (8.0_111-b14) (build 1.8                                                                             .0_111-b14)
# Java VM: Java HotSpot(TM) Embedded Client VM (25.111-b14 mixed mode linux-arm                                                                              )
# Problematic frame:
# C  []  JNI_OnLoad+0x28

I think … its time to buy another zwave-stick, a windows client or a raspberrypi. :disappointed_relieved:

Hi Terflot and Lukasz,

I am new here and found this thread because I am also using the ZME_UZB1 and had some troubles to get it recognized.
Now I could get it running on a Synology DS216j with OpenHAB 2.0.001-SNAPSHOT. I installed the serial driver package, but this thread is the only that mentions it. Are you sure it is really needed?

Now I de-installed the Jadahal UsbSerialDrivers DSM 6.0 and the ZME_UZB1 is still running fine…

Hey, I was using Synology with OH2 under DSM 5 which didnt include drivers. I did not run hab on DSM 6 so this point might be invalid.
If you are not sure about setup of zwave dongle you can always follow other communities guides. System part is the same regardless of home automation software.

Thanks for your feedback :slight_smile: