ZWave status under OH2

Compiled in? Didn’t expect that!
I’ll have a go then, I’m not too experienced with Java, but I guess I anyway need to get the gears up since I’m going for OH, and intend to write my own plugins in the future.


It’s the same in OH1, but in OH2 it’s part of the ESH design…

Considering the Z-Wave database: is it not possible to, say, borrow some data from other open source projects? With asking the maintainers, of course.

Anything is possible, but I’m not sure what this would achieve in the short term? The issue isn’t access to the data, the issue is producing an OH2 format…

Or, maybe I’m missing something?

Aha, I figured something along those lines, and I guess there are reasons behind it, although in the zwave case it sounds a tiny bit inflexible with all those devices arriving to the market. Anyway don’t think I’m complaining - like most I am admiring the work you’ve put in with this! :sunglasses:

See my comment in the following post about why I prefer the database inside the JAR (mainly configuration and quality control).

Hi Crhris
Any news about zwave binding for OH2 ?

1 Like

Right now it seems that daily build doesn’t work. I have tried with the daily bild 11/1-2016 and again 15/1-2016. Both builds starts ZWave and then it is stopping right away. The behaviour can be reproduced both under Windows 10 and Raspberry Pi 2 B (Jessie). My stick is the UZB stick.
I found a daily build on my disk from 26/12-2015, that works. I don’t know what have changed over the 16 days, but obviously the karaf stuff has been introduced.

I would be more than happy in spending some time with testing :smile:

Best Regards

I guess you’re talking about the OH1 binding - the OH2 binding is not released yet. I think I read that there’s a problem after the karaf changes, but that’s not really related to this thread for the OH2 binding…

I’m finalising the database converter at the moment - hopefully this will be ready in a few days (I hope!) and we can then start to get people updating the database.

1 Like


Correct. The reason I mentioned karaf isn’t that it is related with karaf, it is just one change that is quite obvious has taken place for me as user of OH.

If you need help for further investigations, log files or whatever - please don’t hesitate to ask.

I’ve tried the latest download of OH2 and could not get anything z-wave working. I tried both with the offline and online distributions. Is that due that karaf issue you are talking about? I must admit not having spent much time trying to figure it out.
Do the new distribution come with the OH1 Z-Wave bindings resolved? Or do they have to be installed? With the offline, when I put the binding in the addons, it was unable to load the z-wave bindings, due to an unresolved link issue. When I tried in the online distro, it seems to appear but did nothing. Maybe it was my setup that is not working, but my setup files were (partially) working with a previous version of OH2.

Sometimes I wonder if this thread is full of trolls.

The OH2 bindings for Z-Wave have not been released yet. If you can’t wait
for this free software, and have the technical chops it’s possible to
compile from the source yourself.

No need to be snippy. Re-read what I wrote. I was talking about the OH1 bindings being used in OH2, as recommended by Chris. Not talking about the OH2 bindings.

Great news :slight_smile:
Let us know

Yes, OH1 binding works in OH2 and HABmin2 works in OH2.
I have:
OH2 Alpha2 (not beta1 with Karaf) + Z-wave OH1 + HABmin2 = OK

So do you mean it’s working now, or has it always been working for you?

I don’t think anything has changed and I’m seeing issues here when running under Karaf. It’s not a dependancy issue, but possible a startup order issue - hopefully I’ll have it resolved tonight (let’s see!).

1 Like

Damn, sorry.
Not OH2 Beta1 but the ones without Karaf OSGi

I have downloaded the latest snapshot build and tried it on my Raspberry Pi 2 B -

I am beginning to love this new baby (OH 2).

best regards

mhhh i am confused

First: I had the old zwave binding (not working)
Second: I downloaded the latest Habmin for Karaf
Third: Habmin worked; zwave still not
Fourth: I replaced zwave 1.8.0 with latest 1.9.0 snapshot

now neither habmin nor zwave gets active:
Error while starting bundle: file:/addons/org.openhab.ui.habmin_2.0.0.SNAPSHOT-0.0.15.jar
org.osgi.framework.BundleException: Could not resolve module: org.openhab.ui.habmin [184]
Unresolved requirement: Import-Package: org.openhab.binding.zwave.internal.config

I believe you need a complete new build, not just the addon bundles.