Zwave stick changing port - force it to always be ACM0?

I’m implementing monitoring of it as per: Monitor z-wave stick availability (SOLVED)

But recently I’ve found after reboot, or just because, my zwave stick is changing from ACM0 to ACM1. Not sure why, so I’ll deal with can I do something about that first, ie can I force the usb stick to always be ACM0 and not allow it to change. I expect this is more a linux question.

Incidentally this is it resetting I think. Anyone know what it means? Disabled by hub.:

[Wed Jul 31 01:35:09 2019] usb usb8-port2: disabled by hub (EMI?), re-enabling...
[Wed Jul 31 01:35:09 2019] usb 8-2: USB disconnect, device number 3
[Wed Jul 31 01:35:09 2019] usb 8-2: new full-speed USB device number 5 using xhci_hcd
[Wed Jul 31 01:35:09 2019] usb 8-2: New USB device found, idVendor=0658, idProduct=0200, bcdDevice= 0.00
[Wed Jul 31 01:35:09 2019] usb 8-2: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[Wed Jul 31 01:35:09 2019] cdc_acm 8-2:1.0: ttyACM1: USB ACM device

This sound like an OS issue. OpenHAB is not supported on unknown operating systems.

Ubuntu on amd64 wouldn’t be unsupported

That is true, but you did not tell us the OS so we could even make sane suggestions.

I have OH set to look for /dev/zwave which is created via udev rules and then it doesn’t matter what the system loads ACM vs ACM1.

cat /etc/udev/rules.d/99-zwave.rules

SUBSYSTEM=="tty", ATTRS{idVendor}=="0658", ATTRS{idProduct}=="0200", SYMLINK+="zwave", GROUP="dialout"

Keep in mind that this is hardware specific to the AEON Gen 5 stick, which looks like what you have; just wanted to clarify for other readers that use a different Zwave device.

1 Like

I found a post that mentioned something about this and tried it. But it didn’t seem to take for me. Does this trigger only on reboot? Or is there another way to force it to take effect (for debugging)?

I’ve tried moving the usb stick to another port on the machine (Gigabyte Brix A6). I’ll see how that goes.

Correct, there is a way to reload the udev rules or rebooting. Unsure about moving it to other ports, I think this would trigger udev; I typically get it setup before I start working on my OH post installations so I don’t worry about the auto renaming of the device.

Hi guys,
sorry to revive this thread. But I’m trying for days now and just can’t come to a solution.
I have exactly the same problem as psyciknz.
I created the udev rules file and restarted (tried multiple times)

ls -l /dev/zwave

I get:

lrwxrwxrwx 1 root root 7 Nov 24 23:04 /dev/zwave -> ttyACM0

which looks fine to me.
In the zwave controller, I have then set /dev/zwave as the port, but the controller stays offline -> Controller is offline
When I put it to ACM0 it is online for a minute goes offline for a minute (because the port changes) comes online again etc.
Can someone help me please?
Best regards

Hi everyone,
for anyone with the same problem reading this in the future:
This post solved it for me. It is needed additionally to the udev changes for openhab to be allowed to use the new port.

Best regards