Zwave stick: OFFLINE - BRIDGE_OFFLINE Controller is offline


I am unable to add the Anotec Z-stick Gen5.

OH version: 2.5.0-1

This is what I did so far:

  • Added the zwave binding via the addons.cfg file
  • Inserted the stick in my rpi
  • Added the stick via things

The message I get is “Bridge Offline”

Log file:

2019-12-28 16:55:07.293 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Connecting to serial port '/dev/ttyAMA0'

2019-12-28 16:55:07.316 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Serial port is initialized

2019-12-28 16:55:07.341 [INFO ] [ve.internal.protocol.ZWaveController] - Starting ZWave controller

2019-12-28 16:55:07.342 [INFO ] [ve.internal.protocol.ZWaveController] - ZWave timeout is set to 5000ms. Soft reset is false.

dmesg|grep tty gave me:

[    0.000000] Kernel command line: coherent_pool=1M 8250.nr_uarts=0 cma=64M cma=256M  smsc95xx.macaddr=DC:A6:32:27:F4:92 vc_mem.mem_base=0x3f000000 vc_mem.mem_size=0x3f600000  dwc_otg.lpm_enable=0 console=ttyS0,115200 console=tty1 root=PARTUUID=abd712b8-02 rootfstype=ext4 elevator=deadline rootwait
[    0.000704] console [tty1] enabled
[    0.852441] fe201000.serial: ttyAMA0 at MMIO 0xfe201000 (irq = 34, base_baud = 0) is a PL011 rev2

I did the same on another rpi and there it worked flawlesly… I really don’t understand.

Are you sure the serial port selection is correct?

There is only one port I can select

Anyone an idea?

Is this on a Pi 4?
You need to add a USB2 hub between the stick and the Pi. The stick reports as USB3 capable when it is not. I think another solution is to connect it to the USB2 port on the Pi.

Thanks for your reply Bruce!
I also had a Pi3, so I moved my OH to the 3 model

in my case it is same status of the controller if i put it on the usb 2 port on rpi 4

I think I saw one case where that worked here but there are many cases around the Internet where a powered USB2 hub worked. That is the workaround mentioned by official Raspberry Pi support on the forums too.