ZWave Stopped - Help Please

Hi all,

Openhab: 2.5.x (multiple tried - all Docker containers)
O/S: Ubuntu Linux 18.04
Zwave controller: Aeotec ZStick

My Zwave network has ground to a halt after 12+ months of working properly. There are a variety of errors showing in HABmin and PaperUI but the most telling is the logs:

Exception in thread "ZWaveReceiveProcessorThread" java.lang.NullPointerException
	at org.openhab.binding.zwave.internal.protocol.ZWaveTransactionManager$

java.lang.IllegalStateException: Queue full
	at java.util.AbstractQueue.add( ~[?:1.8.0_232]
	at java.util.concurrent.ArrayBlockingQueue.add( ~[?:1.8.0_232]
	at org.openhab.binding.zwave.internal.protocol.ZWaveTransactionManager.processReceiveMessage( ~[bundleFile:?]
	at org.openhab.binding.zwave.internal.protocol.ZWaveController.incomingPacket( ~[bundleFile:?]
	at org.openhab.binding.zwave.handler.ZWaveControllerHandler.incomingMessage( ~[bundleFile:?]
	at org.openhab.binding.zwave.handler.ZWaveSerialHandler$ [bundleFile:?]

I have reinstalled just about everything, switched out Aeotec Z-Sticks, deleted all the ZWave Things but to no avail.

All help appreciated.

Try turning off the zwave daily heal and then restart OH. There are several posts about this. Also, use the PC Controller app to find and remove ghost nodes.

Thanks, trying that now; and I was able to remove three dead nodes.

The error seems to have been resolved (not showing in the logs), but the Zwave network isn’t responding to OpenHAB. HABmin shows all the nodes online but they aren’t responding to state changes. Weirdly enough the Network Viewer isn’t working, it shows a single line. However, the Network displays properly in the Zensys tool.

Do you have a pointer for this pc controller app?

I just upgraded to 2.5 and while I haven’t had my network stop, I have a ghost node from something that was deinstalled, and another switch that has not fully populated its data.

PC Controller is the new name for Zensys Tools. You can download it from SilconLabs. There are several topics discussing it. If you haven’t tried, you may also be able to remove the node through the zwave binding.

Yeah I had the same issue. Disable nightly heal, use the Zensys tools to remove any nodes that are failed but still there. That worked for me.

I gave up - somehow there was a corruption in the database and/or the controller as I kept getting zwave binding errors (null pointer exceptions, queue full etc etc).

I have hard reset one of my controllers and am in the slow process of adding the zwave devices back one at a time. Everything seems to be working so far.

The disable nightly heal will stop this. Had the same issue.