Zwave: Suddenly a lot of Protocol error (CAN)

I’am running OpenHAB on a BeagleBone Black using an Aeon Z-Stick gen 5. My setup did work good for months and now I suddenly get a lot of “Protocol error (CAN), resending” errors in the log and a lot of values from my power switches are not refreshed.

I’ve got one dead device that is currently not powered, but the device wasn’t connected before and didn’t cause any such problems. What could cause such a problem?

I get that periodically. It tends to resolve itself after awhile. A couple of times one of my nodes ended up marked dead by the controller and I had to re-add it. Check your network in habmin also and make sure you don’t have any choke points. I discovered that only one of my nodes could see the controller so ALL zwave traffic was being handled by one wall switch. Since I added a new device which gave another path to the controller I’ve noticed those errors go away almost completely.

Almost all of my nodes have a direct connection to the Z-Stick regarding the network diagram in habmin, so this could not be the problem.

I’ve now connected all devices, but I’m still having a lot of problems. Now I also get “Meter Report: Buffer too short: length=6, required=7” errors in my log. I’ve uploaded the whole log to pastebin:

Does anyone have an idea what could cause this and how to fix this?

Edit: After a reboot of OpenHAB everything works fine for a couple of hours, but then a lot of values are not refreshed.

This error means that the data received is shorter than it should be and it can’t be processed.

What system are you running OH on? Is it a standalone computer, or in a VM or…?

My OpenHAB runs on a BeagleBone Black. But I think I could solve this particular buffer error by changing some of the parameters of my Aeon MSS2E device. (I think setting the parameter 80 to deactivate solved this problem) But I’m still having problems with my Aeon SES3 switches. After a few hours the power usage is not updated anymore.

Well, I’m happy to look at a debug log to see if I can see anything in the log if you want to provide one, but if you’re getting a lot of CAN errors then it probably indicates something fundimentally wrong somewhere - although I don’t know what. A CAN error means that the controller has dropped the frame for some reason.

I’ve uploaded a ZIP file containing a 15 minute z-wave trace log and the device xml files to my Google Drive:

The log looks ok - there are 2 or 3 CAN errors, but nothing that looks systematic, and there are no other errors such as the buffer length problem. There are also two message timeouts at the beginning so a couple of nodes might not have the best communications within the network, but it’s hard to point at anything especially wrong.

Thanks for analyzing the log. It seams that often when I try to send an ON or OFF command to one of my Z-Wave switches the command runs into an timeout and the watt values are still not refreshing. Also I never get watt values from node 18, (Even after a restart of OpenHAB) but that could be a hardware problem.

Do you have any other ideas what could cause such a problem?

Edit: I just found some other errors regarding Z-Wave in the openhab.log:

I would try deleting the dead device to see if that helps - the binding will still try to communicate with it periodically, and this can cause errors.

What version of the binding are you using? I think it’s 1.8.x - you should use 1.9.x snapshots as there’s a bug in 1.8.x that causes the other error you found in the main log.

I found out that one of my smoke detectors was not included in my zwave network anymore. I did a reset of the device and included it as a new node, now it is working again. I’ve also compiled a 1.9 zwave binding using the latest source code and now there are much less errors in my log.

It seams now as everything is working again. The only problem is that I cannot get rid of the old node from my smoke detector. It seams that I can only delete nodes that are marked as dead. Is there a way to mark this node as dead and delete it?

Edit: In the log I found the following error: Remove failed node failed as node not found!

Edit2: I’ve managed it to remove the old node using the Open-Zwave Control Panel.