ZWave with Fibaro FGSD-002 doesn't work

Hey guys,

this is my first Thread on this page. I hope you guys can help me.
I’ve bought a Fibaro FGSS-002 Smoke detector. I’ve got a RazBerry on my Raspberry and it works pretty well with the z-way-server (the original software from the daughter board). My Smoke detector has got the ID 2 and as I said, no problems with that system.
But when it comes to openhab, it just doesn’t work. I do not get values for alarm and neither for battery status.

My items:
Contact BueroH_SD_Smoke "Alarm test" <fire> (gSmoke) { zwave="2:command=alarm,respond_to_basic=true" } Number BueroH_SD_Bat "Battery test [%s %%]" <battery> (gBattery) { zwave="2:command=battery,respond_to_basic=true" }
I’ve noticed, that it is updating the Temperature status! I’ve seen it in the logs. Strange…
I also tried to wake it up manually. Does not change anything
My logs:

Openhab, INFO

I hope you guys can help me

Kind regards

Try this:

Contact    BueroH_SD_Smoke   "Alarm test"  <fire> (gSmoke)   { zwave="2:command=sensor_alarm,alarm_type=1" }

Number BueroH_SD_Bat "Battery test [%s %%]"  <battery> (gBattery) {zwave="2:command=battery"}

By the way, I could nowhere find a device called FGSS 002, so my config example is a wild guess, is it new or did you type a wrong name?

Edit: and make sure you have the correct association group set: in most cases it is called "Device Status or Controller Updates or Group 1 or whatever, it should be set to the Controller (normally node 1)

Whuups, wrong name! It’s the Fibaro FGSD-002. Shame on me!
Thanks for your answere. I will try the alarm tomorrow with your changes.

I’ve already did the association. It was suggested in another topic so I tried it out,
but the battery status still does not get updated(already removed the “respond to basic …”). It’s just uninitialized.
Any ideas?

Take a look at the wakeup period: you won’t get any battery report until that time is gone by.

Thanks, I already did. It's on 270, and unfortunately even manual wakeup does not change the battery status item. I've waited for 24 hours now.

Hmmm, then take a look at this post, he claims to have a working config:

Continuing the discussion from Rule with the Fibaro Smoke Sensor:

Works great with the suggested configuration! Except for battery status everything is working now. Thank you!

Try exchanging the %s with %d:

Number BueroH_SD_Bat "Battery test [%d %%]" <battery> (gBattery) { zwave="2:command=battery" }

1 Like

Omg, finally!! It works. Thank you so much!