ZWave Wrong identification of manufacturer / model of Door / Window sensor

I’m using the stable release.

Uninstall the stable binding, download the snapshot zwave jar from cloudbees, drop it into your addons folder, delete all things, readd all things.
You may need to clear cache and tmp and restart openHAB to make it work.

I did that, but on the Paper UI/add ons/Binding page I see the ols binding-zwave - 2.3.0 and not the 2.4.0 that I have downloaded.

Few thins to note:

  • My addons directory is /usr/share/openhab2/addons
  • On that directory there was only two files: openhab-addons-2.3.0.kar and README
  • I added to that directory the org.openhab.binding.zwave-2.4.0-SNAPSHOT.jar file
  • I did the cache cleaning (including the tmp dir) and stop/start the openhab2.service

Tx, Meir

You won’t see any bindings in PaperUI which are manually installed through your addons folder.
Check via karaf which binding is active.

I checked.
The new binding is installed but not active.
How do I make it active and how do I set its serial port to /dev/ttyAMA0?

First make sure you properly uninstalled the stable binding.
Then perform a bundle:start XXX where XXX is the number from your installed, but not active snapshot binding.

You may need to also install the serial transport dependency:

Add your controller as Thing and then set the correct port in the properties of that Thing.

Thank you very much.
I did as you told and indeed it is active now.
btw, I started learing using the karaf console and it is great. I’m extending my openhab knowledge all the time.

There is (hopefully) one problem.
I added the z-wave controller to my ‘Things’’, but when configuring it, the “serial port” field is missing - so I can’t set it to /dev/ttyAMA0.

Thanks again,

This is how this Z-Wave controller config looks:

The “port” field is missing

Normally, this is what you will see if the binding is not running - is the controller online? If not, what is the state? Are you sure the binding is running (I know you said it is, but, just checking… :wink: )?

You are right
I did bundle:start 186 (my zwave id) and went to Paper UI, Clicked Add thing and saw the Z-Wave Contrtoller Thing.

But now I ran again the following command and it is “Installed” and not “Active”

bundle:list | grep ZWave

186 │ Installed │ 80 │ │ ZWave Binding

I nran also the thins list:
smarthome:things list

zwave:serial_zstick:ed57d759 (Type=Thing, Status=UNINITIALIZED, Label=Razberry Board 2016 Z-Wave Controller, Bridge=null)

Normally a bundle won’t start if it’s missing dependencies. I think the only dependency that is likely to be missing is the serial driver.

Try typing feature:install openhab-transport-serial in karaf and see if it starts.

Something wiered:

I did the followings:

  • feature:install openhab-transport-serial
  • bundle:start 186
  • bundle:list | grep ZWave (186 │ Active │ 80 │ │ ZWave Binding)

but few hour later it went back to installed state

and gain it “complained” on the missing “

Clear the cache

and install the serial transport again (has to be performed after each clearing of tmp and cache)

This is what is installed by the serial feature, so I guess this is being removed somehow.

  • I stopped the OH service (sudo systemctl stop openhab2.service)

  • I cleaned the cache (both cache and tmp sub directories)

  • I ran OH service (sudo systemctl stop openhab2.service)

  • I ran the console (sudo openhab-cli)

  • I imported the transport serial (feature:install openhab-transport-serial)

  • I started the ZWave bundle (bundle:start 189)

  • I checked that it is active (bundle:list | grep ZWave ===> 189 │ Active │ 80 │ │ ZWave Binding)

  • I configure the port:

  • I got “Server Internal Error” message:

  • looking at the openhab.log is see this error:
    2018-09-30 12:23:30.432 [ERROR] [st.core.internal.thing.ThingResource] - Exception during HTTP PUT request for update config at ‘things/zwave:serial_zstick:ed57d759/config’
    java.lang.IllegalStateException: Thing with UID zwave:serial_zstick:ed57d759 has no handler attached.
    at org.eclipse.smarthome.core.thing.internal.ThingRegistryImpl.updateConfiguration( [108:org.eclipse.smarthome.core.thing:0.10.0.oh230]
    at []
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:?]

Never seen that error, are you sure you have the correct port?

Check via dmesg | grep tty

sudo dmesg | grep tty

[ 0.000000] Kernel command line: 8250.nr_uarts=1 bcm2708_fb.fbwidth=1824 bcm2708_fb.fbheight=984 bcm2708_fb.fbdepth=16 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3f000000 vc_mem.mem_size=0x3f600000 dwc_otg.lpm_enable=0 console=tty1 root=PARTUUID=e9283127-02 rootfstype=ext4 elevator=deadline rootwait
[ 0.000809] console [tty1] enabled
[ 0.894026] 3f201000.serial: ttyAMA0 at MMIO 0x3f201000 (irq = 87, base_baud = 0) is a PL011 rev2
[ 2.628378] systemd[1]: Created slice system-getty.slice.

Looks good, no more ideas.
Edit: Does your openhab user belong to tty group?

Yes, I added it to tty and dialout groups